<!DOCTYPE html>
<html lang="en" dir="ltr" >

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="apple-touch-icon" href="//www.yazooherald.net/sites/default/files/yazoo-favicon_1.jpg" type="image/jpeg" />
<meta property="og:type" content="Article" /><meta property="og:title" content="Henry Brickell memorial service to be held on Nov. 22"/><meta property="og:url" content="https://www.yazooherald.net/news/henry-brickell-memorial-service-be-held-nov-22"/><meta property="og:image" content="//www.yazooherald.net/sites/default/files/TheYazooHeraldWebLogo2.png"/><meta property="fb:admins" content="dgustoughson"><meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="/news/henry-brickell-memorial-service-be-held-nov-22" />
<link rel="shortlink" href="/node/5297" />
<link rel="shortcut icon" href="//www.yazooherald.net/sites/default/files/yazoo-favicon_2.jpg" type="image/jpeg" />
  <title>Henry Brickell memorial service to be held on Nov. 22 | The Yazoo Herald</title>  
  <style type="text/css" media="all">
@import url("//www.yazooherald.net/modules/system/system.base.css?q0npcl");
@import url("//www.yazooherald.net/modules/system/system.menus.css?q0npcl");
@import url("//www.yazooherald.net/modules/system/system.messages.css?q0npcl");
@import url("//www.yazooherald.net/modules/system/system.theme.css?q0npcl");
</style>
<style type="text/css" media="all">
@import url("//www.yazooherald.net/misc/ui/jquery.ui.core.css?q0npcl");
@import url("//www.yazooherald.net/misc/ui/jquery.ui.theme.css?q0npcl");
@import url("//www.yazooherald.net/misc/ui/jquery.ui.button.css?q0npcl");
@import url("//www.yazooherald.net/misc/ui/jquery.ui.resizable.css?q0npcl");
@import url("//www.yazooherald.net/misc/ui/jquery.ui.dialog.css?q0npcl");
</style>
<style type="text/css" media="all">
@import url("//www.yazooherald.net/modules/aggregator/aggregator.css?q0npcl");
@import url("//www.yazooherald.net/sites/all/modules/calendar/css/calendar_multiday.css?q0npcl");
@import url("//www.yazooherald.net/sites/all/modules/date/date_api/date.css?q0npcl");
@import url("//www.yazooherald.net/sites/all/modules/date/date_popup/themes/datepicker.1.7.css?q0npcl");
@import url("//www.yazooherald.net/modules/field/theme/field.css?q0npcl");
@import url("//www.yazooherald.net/modules/node/node.css?q0npcl");
@import url("//www.yazooherald.net/modules/search/search.css?q0npcl");
@import url("//www.yazooherald.net/sites/all/modules/simpleads/simpleads.css?q0npcl");
@import url("//www.yazooherald.net/sites/all/modules/ubercart/uc_order/uc_order.css?q0npcl");
@import url("//www.yazooherald.net/sites/all/modules/ubercart/uc_product/uc_product.css?q0npcl");
@import url("//www.yazooherald.net/sites/all/modules/ubercart/uc_store/uc_store.css?q0npcl");
@import url("//www.yazooherald.net/modules/user/user.css?q0npcl");
@import url("//www.yazooherald.net/sites/all/modules/views/css/views.css?q0npcl");
</style>
<style type="text/css" media="all">
@import url("//www.yazooherald.net/sites/all/modules/ed_classified/theme/classified.css?q0npcl");
@import url("//www.yazooherald.net/sites/all/modules/ctools/css/ctools.css?q0npcl");
@import url("//www.yazooherald.net/sites/all/modules/event_calendar/event_popup/css/event_popup.css?q0npcl");
@import url("//www.yazooherald.net/sites/all/modules/ctools/css/modal.css?q0npcl");
@import url("//www.yazooherald.net/sites/all/modules/responsive_menus/styles/responsive_menus_simple/css/responsive_menus_simple.css?q0npcl");
</style>
<link type="text/css" rel="stylesheet" href="/sites/all/modules/custom/emmerich_notifications/css/style.css" media="all" />
<style type="text/css" media="all">
@import url("//www.yazooherald.net/sites/all/modules/quicktabs/css/quicktabs.css?q0npcl");
</style>
<style type="text/css" media="all">
@import url("//www.yazooherald.net/sites/all/themes/bones/css/normalize.css?q0npcl");
@import url("//www.yazooherald.net/sites/all/themes/bones/css/formalize.css?q0npcl");
@import url("//www.yazooherald.net/sites/all/themes/bones/css/grid_12.css?q0npcl");
@import url("//www.yazooherald.net/sites/all/themes/bones/css/layout.css?q0npcl");
</style>
<style type="text/css" media="all">
@import url("//www.yazooherald.net/sites/all/themes/current/css/style4.css?q0npcl");
@import url("//www.yazooherald.net/sites/all/themes/current/css/responsive.css?q0npcl");
@import url("//www.yazooherald.net/sites/all/themes/current/css/custom.css?q0npcl");
</style>
  <script type="text/javascript" src="//www.yazooherald.net/misc/jquery.js?v=1.4.4"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/jquery-extend-3.4.0.js?v=1.4.4"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/jquery.once.js?v=1.2"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.slots = googletag.slots || {};
//--><!]]>
</script>
<script type="text/javascript" src="//www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/drupal.js?q0npcl"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.core.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.widget.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.button.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.mouse.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.draggable.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.position.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.resizable.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.dialog.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/views/js/jquery.ui.dialog.patch.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/jquery.cookie.js?v=1.0"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/jquery.form.js?v=2.52"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ajax.js?v=7.67"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/simpleads/simpleads.js?q0npcl"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/simpleads/modules/simpleads_campaigns/simpleads_campaigns.js?q0npcl"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
googletag.cmd.push(function() {
  googletag.pubads().enableAsyncRendering();
  googletag.pubads().enableSingleRequest();
  googletag.pubads().collapseEmptyDivs();
});

googletag.enableServices();
//--><!]]>
</script>
<script type="text/javascript" src="//www.yazooherald.net/misc/progress.js?q0npcl"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/event_calendar/event_popup/js/event_popup.js?q0npcl"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/event_calendar/event_popup/js/event_popup_validate.js?q0npcl"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery(document).ready(function($) { 
    $.expr[':'].regex = function(elem, index, match) {
            var matchParams = match[3].split(','),
            validLabels = /^(data|css):/,
            attr = {
                method: matchParams[0].match(validLabels) ? 
                matchParams[0].split(':')[0] : 'attr',
                property: matchParams.shift().replace(validLabels,'')
            },
            regexFlags = 'ig',
            regex = new RegExp(matchParams.join('').replace(/^\s+|\s+$/g,''), regexFlags);
            return regex.test(jQuery(elem)[attr.method](attr.property));
        }
    });
//--><!]]>
</script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/ctools/js/modal.js?q0npcl"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/views/js/base.js?q0npcl"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/views/js/ajax_view.js?q0npcl"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var switchTo5x = true;var useFastShare = true;
//--><!]]>
</script>
<script type="text/javascript" src="https://ws.sharethis.com/button/buttons.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (typeof stLight !== 'undefined') { stLight.options({"publisher":"fc937732-3d58-4754-8720-1d210502838c","version":"5x","doNotCopy":false,"hashAddressBar":true,"doNotHash":false,"onhover":false,"newOrZero":"zero","lang":"en"}); }
//--><!]]>
</script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/responsive_menus/styles/responsive_menus_simple/js/responsive_menus_simple.js?q0npcl"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/google_analytics/googleanalytics.js?q0npcl"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","//www.google-analytics.com/analytics.js","ga");ga("create", "UA-75225316-16", {"cookieDomain":"auto"});ga("set", "anonymizeIp", true);ga("send", "pageview");
//--><!]]>
</script>
<script type="text/javascript" src="/sites/all/modules/custom/emmerich_notifications/js/script.js"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/fb_likebox/fb_likebox.js?q0npcl"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/quicktabs/js/quicktabs.js?q0npcl"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/bones/js/jquery.formalize.min.js?q0npcl"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/bones/js/superfish.js?q0npcl"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/current/js/scripts.js?q0npcl"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/bones/js/jquery.easing.1.3.js?q0npcl"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/bones/js/jquery.equal-height-columns.js?q0npcl"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/current/js/jquery.mobilemenu.min.js?q0npcl"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/current/js/jquery.color.js?q0npcl"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/current/js/jquery-glowing.js?q0npcl"></script>
<script type="text/javascript">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</script>
  <meta name="viewport" content="width=device-width, initial-scale=1">  
  <!--[if lt IE 9]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
  <link href='//fonts.googleapis.com/css?family=Paytone+One' rel='stylesheet' type='text/css'>
  <script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-8039211595423832",
    enable_page_level_ads: true
  });
</script>
<script src="https://cdn.broadstreetads.com/init-2.min.js"></script>
<script>broadstreet.watch({ networkId: 6296 })</script>

</head>

<body class="html not-front not-logged-in one-sidebar sidebar-second page-node page-node- page-node-5297 node-type-article sidebars-split news henry-brickell-memorial-service-be-held-nov-22">
  <div id="skip-link">
    <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    <div id="page">

  <div class="user-menu-wrapper"><div class="user-menu-wrapper-inner container_12">  
    <nav id="user-menu" class="grid_12 clearfix">
        <div class="region region-user-menu">
    <div id="block-system-user-menu" class="block block-system block-menu"><div class="block-inner">

	      <h3 class="title"><span>User menu</span></h3>
     
  <div class="content">
		<ul class="menu"><li class="first last leaf"><a href="/user/login" title=""><span>Login</span></a></li>
</ul>  </div>

</div></div>   </div>
        <div class="region region-search-box">
    <div id="block-search-form" class="block block-search"><div class="block-inner">

	     
  <div class="content">
		<form onsubmit="if(this.search_block_form.value==&#039;Search&#039;){ alert(&#039;Please enter a search&#039;); return false; }" action="/news/henry-brickell-memorial-service-be-held-nov-22" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." onblur="if (this.value == &#039;&#039;) {this.value = &#039;Search&#039;;}" onfocus="if (this.value == &#039;Search&#039;) {this.value = &#039;&#039;;}" type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-0-p-NdHh0e3zCZUqeMosQaqY5vF1xP3Wchp1dH_kRL4" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form>  </div>

</div></div>   </div>
      <div id="social">
        <ul class="social-links">
          <li><a class="rss" href="/rss.xml"></a></li>
          <li><a class="twitter" href="http://www.twitter.com"></a></li>
          <li><a class="facebook" href="http://www.facebook.com"></a></li>
        </ul>
      </div>         
    </nav>
  </div></div>

  <div class="header-wrapper"><div class="header-wrapper-inner container_12">
    <header class="grid_12 clearfix">
            <div class="logo-slogan">  
        
                  <div class="site-logo">
            <a href="/"><img src="//www.yazooherald.net/sites/default/files/TheYazooHeraldWebLogo2.png" alt="" /></a>
          </div>
        	      
        
        <hgroup>
        
                    
                     
        
        </hgroup> 
  
      </div>

           
    </header>  
    
  </div></div>

      
    <div class="main-menu-wrapper"><div class="main-menu-wrapper-inner container_12">  
      <nav id="main-menu" class="grid_12 clearfix">
          <div class="region region-main-menu">
    <div id="block-system-main-menu" class="block block-system block-menu"><div class="block-inner">

	      <h3 class="title"><span>Main menu</span></h3>
     
  <div class="content">
		<ul class="menu"><li class="first expanded"><a href="/" title="Home"><span>Home</span></a><ul class="menu"><li class="first leaf"><a href="/about-us"><span>About Us</span></a></li>
<li class="leaf"><a href="/our-staff" title="Our Staff"><span>Our Staff</span></a></li>
<li class="leaf"><a href="/faqs" title="FAQ&#039;s"><span>FAQ&#039;s</span></a></li>
<li class="leaf"><a href="/contact-us" title="Contact Us"><span>Contact Us</span></a></li>
<li class="last leaf"><a href="/monthly-website-statistics" title=""><span>Monthly Website Statistics</span></a></li>
</ul></li>
<li class="leaf"><a href="http://yazooherald.net/eedition-front" title=""><span>E-Edition</span></a></li>
<li class="leaf"><a href="/obituaries" title="Obituaries"><span>Obituaries</span></a></li>
<li class="leaf"><a href="/taxonomy/term/4" title="Sports"><span>Sports</span></a></li>
<li class="expanded"><a href="/opinion" title="Opinion"><span>Opinion</span></a><ul class="menu"><li class="first leaf"><a href="/columnists" title="Columnists"><span>Columnists</span></a></li>
<li class="leaf"><a href="/editorials" title="Editorials"><span>Editorials</span></a></li>
<li class="last leaf"><a href="/letters-editor" title="Letters to the Editor"><span>Letters to the Editor</span></a></li>
</ul></li>
<li class="expanded"><a href="/classified" title=""><span>Advertising</span></a><ul class="menu"><li class="first leaf"><a href="/classified/75" title=""><span>Legal Notices</span></a></li>
<li class="leaf"><a href="/newspaper-rates"><span>Newspaper Rates</span></a></li>
<li class="leaf"><a href="http://yazooherald.net/place-classified-ad-1" title=""><span>Place a Classified Ad</span></a></li>
<li class="last leaf"><a href="/website-rates"><span>Website Rates</span></a></li>
</ul></li>
<li class="expanded"><a href="/subscribe"><span>Subscribe</span></a><ul class="menu"><li class="first last leaf"><a href="/yazoo-herald"><span>The Yazoo Herald</span></a></li>
</ul></li>
<li class="last collapsed"><a href="/news"><span>News</span></a></li>
</ul>  </div>

</div></div>   </div>
      </nav>
    </div></div> 
      
  
  <div class="main-menu-second-level-wrapper clearfix"><div class="main-menu-second-level-wrapper-inner container_12">  
    <nav id="main-menu-second-level" class="grid_12">
            
    </nav>
  </div></div> 
  
<!-- Main Content -->  
  <div class="main-content-wrapper"><div class="main-content-wrapper-inner container_12">
    <section id="main-content" class="clearfix"> 	   

          
    
      <div class="main">
        <div class="main-inner  grid_6">
                    
	      
        
                                          
          <div class="main-inner-wrp">
            <div class="region region-content-top">
    <div id="block-block-56" class="block block-block adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='75031' zone-alias='yaz_top_leaderboard'></broadstreet-zone>
  </div>

</div></div>   </div>
                                          <div class="region region-content">
    <div id="block-system-main" class="block block-system"><div class="block-inner">

	     
  <div class="content">
		<article id="node-5297" class="node node-article node-promoted last clearfix">



  


  


  <div class="node-content-wrapper">



    


      


      
       <h1 class="title">Henry Brickell memorial service to be held on Nov. 22</h1>

      


    


    By <A HREF="/AUTHOR-CONTENT/184"><SPAN>THE YAZOO HERALD</SPAN></A>,


    
        <ul class="links inline"><li class="statistics_counter first last"><span>288 reads</span></li>
</ul>
    


    
      <div class="submitted">

            <span class="date">Fri, 11/15/2019 - 6:21pm</span>

      </div>

    


    <div class="content">

    <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even"> <p>A memorial service for Yazoo native Henry Mitchell Brickell, a noted education researcher and reformer, will be held in Yazoo City next week.</p>
<p>Brickell, only a few days shy of his 93rd birthday, died on Oct. 25, 2019. His memorial service will be held on Nov. 22 at 1 p.m. at the First Presbyterian Church with his burial following in Glenwood Cemetery.</p>
<p>Brickell was born in Yazoo City on Nov. 3, 1926, to Missye King (Gibson) and Carey Manuel Brickell, Sr.; their ancestors reached the South in colonial times, Mississippi in the 1770s, and Yazoo City in the 1830s. He spent his youth in Yazoo City, New Orleans, and Jacksonville, and then left home to earn a B.A. from Ohio State University, an M.A. from the University of Chicago, and a second M.A. and an Ed.D. from Columbia University Teachers College in 1953.</p>
<p>His work is commemorated in a plaque in the Yazoo Memorial Literary Walkway, which is named for his uncle, the editor and critic Henry Herschel Brickell. He is a childhood friend of Samuel B. Olden, playmate and cousin of the late Virginia Brickell, and cousin of Marsha Williams of Yazoo City.</p>
<p>He set an extremely high bar for himself and others and made short work of his first teaching job when, as advisor to the school newspaper, and frustrated by student reporters missing deadlines, he published an issue of the paper with blank spaces featuring bylines such as, “This space was supposed to have been filled by John Smith.”</p>
<p>A few years and a few jobs later, he created a unique system for organizing the policies, regulations, and bylaws of local school systems. This innovation was published as the Davies-Brickell System and is the basis for the policy systems that are used today in most school districts across the country.</p>
<p>After receiving his doctorate, Dr. Brickell was recruited by the public-school system in Manhasset, New York, which was benefitting from post-war growth on the North Shore of Long Island.  By 1966 he had risen to become the assistant superintendent of schools. When New York’s Governor Nelson Rockefeller sought improvements in education in the state, Dr. Brickell was appointed by Commissioner James E. Allen to write a seminal study, published by the New York State Education Department in 1961 under the title Organizing New York State for Educational Change. Implemented in succeeding years, it helped to establish New York’s leading place in elementary and secondary education.</p><div class="ad">
        <div class="left"><div id="block-block-58" class="block block-block adServeMargin "><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='75551' zone-alias='yaz_top_left_in-story_medium_rectangle'></broadstreet-zone>
  </div>

</div></div> </div>
        </div>
<p>As he developed a national reputation, Dr. Brickell was asked by colleges and universities to educate the educators. He taught at Stanford University and New York University and was brought to Indiana University’s flagship campus in Bloomington from 1966 to 1969, where he served as the associate dean of the School of Education. He strongly believed that principals should spend time in classrooms observing teaching practices for, as he said, “supervision is the over-the-shoulder prevention of mistakes.”</p>
<p>Returning in 1969 to Manhasset with his wife and four children, Dr. Brickell established in 1973 his own nonprofit organization, Policy Studies in Education, with offices in New York City. Conducting more than 500 projects in the ensuing 45 years, that nonprofit consultancy worked with hundreds of school districts in most states to improve K-12 education and conducted studies for more than 200 colleges. Dr. Brickell also directed studies for state education departments, state legislatures, foundations, and national professional associations. He wrote numerous books and articles and was a prominent national speaker on topics including educational evaluation and school governance.</p>
<p>Dr. Brickell was named to the panel that chose the original sites for federally funded research and development laboratories and centers. He also served as a long-term advisor to the Northwest Regional Educational Laboratory, the National Center for Research in Vocational Education, Research for Better Schools, and the Council of Educational Development and Research.</p>
<p>A firm yet loving parent, ever in teaching mode and usually traveling, he was willing on weekends to help one of his children review key concepts or edit an essay, but he preferred to enlist all of them in much-needed home maintenance projects such as yard work, repairs, or painting. He will be remembered by his children and grandchildren for coining phrases like, “The moving van is at the door” (used to convey urgency) and, “Things don’t break; people break things” (used to place responsibility).</p>
<p>He is mourned by his wife of 68 years, Mary (Daly) Brickell; his children Mark, Julia, Sally, and Todd Brickell and their spouses; 11 grandchildren with three spouses; four great grandchildren; members of the Brickell, Breazeale, and Marks families who descend from his brothers, Carey and Herschel; descendants of his mother’s second husband, the late Harold D. Miller of Jackson, and many other family members and friends.</p>
<p>In lieu of flowers, donations may be made to the non-profit Yazoo Historical Society or the Manhasset Student Aid Association (co-founded by Mary Brickell), which provides financial assistance to help students achieve the goal of a college education.</p>
 </div></div></div><div class="item-list"><ul class="pager-for-content-type flippy"><li class="pager-previous prev first"><a href="/lifestyles/miss-mohamed-wed-mccaleb#node-5296" class="prev"><span>‹ Previous</span></a></li>
<li class="pager-next next last"><a href="/news/washington-named-president-yazoo-county-fair-civic-league#node-5298" class="next"><span>Next ›</span></a></li>
</ul></div>
    </div>







    
      <nav class="taxonomy"><div class="taxonomy-inner clearfix">

        
      </div></nav>

    


  
      <nav class="taxonomy"><div class="taxonomy-inner clearfix">

        
      </div></nav>

    


 






  </div>





</article>




  </div>

</div></div> <div id="block-sharethis-sharethis-block" class="block block-sharethis"><div class="block-inner">

	     
  <div class="content">
		<div class="sharethis-wrapper"><span st_url="https://www.yazooherald.net/news/henry-brickell-memorial-service-be-held-nov-22" st_title="Henry Brickell memorial service to be held on Nov. 22" class="st_facebook_button" displayText="facebook"></span>
<span st_url="https://www.yazooherald.net/news/henry-brickell-memorial-service-be-held-nov-22" st_title="Henry Brickell memorial service to be held on Nov. 22" class="st_twitter_button" displayText="twitter" st_via="" st_username=""></span>
<span st_url="https://www.yazooherald.net/news/henry-brickell-memorial-service-be-held-nov-22" st_title="Henry Brickell memorial service to be held on Nov. 22" class="st_pinterest_button" displayText="pinterest" st_via="" st_username=""></span>
<span st_url="https://www.yazooherald.net/news/henry-brickell-memorial-service-be-held-nov-22" st_title="Henry Brickell memorial service to be held on Nov. 22" class="st_tumblr_button" displayText="tumblr" st_via="" st_username=""></span>
<span st_url="https://www.yazooherald.net/news/henry-brickell-memorial-service-be-held-nov-22" st_title="Henry Brickell memorial service to be held on Nov. 22" class="st_email_button" displayText="email" st_via="" st_username=""></span>
<span st_url="https://www.yazooherald.net/news/henry-brickell-memorial-service-be-held-nov-22" st_title="Henry Brickell memorial service to be held on Nov. 22" class="st_fblike_button" displayText="fblike" st_via="" st_username=""></span>
</div>  </div>

</div></div> <div id="block-facebook-comments-box-facebook-comments-box" class="block block-facebook-comments-box"><div class="block-inner">

	     
  <div class="content">
		<div class="facebook-comments-box"><div id="fb-root"></div><script src="http://connect.facebook.net/en_US/all.js#xfbml=1"></script><fb:comments href="https://www.yazooherald.net/news/henry-brickell-memorial-service-be-held-nov-22"  num_posts="10"  width="580"  colorscheme="light" ></fb:comments></div>  </div>

</div></div> <div id="block-block-57" class="block block-block adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='75626' zone-alias='yaz_medium_leaderboard'></broadstreet-zone>
  </div>

</div></div>   </div>
  
                  
                              </div> 
        </div> 
                <aside class="sidebar second-sidebar grid_6">
          <div class="sidebar-wrp">
              <div class="region region-second-ad">
    <div id="block-block-39" class="block block-block sign-up-for-emmerich-notifications"><div class="block-inner">

	      <h3 class="title"><span>Sign Up for Notifications of Local Breaking News</span></h3>
     
  <div class="content">
		<p><a class="ctools-use-modal start" href="/emmerich/subscribe/email/js">Start E-mail Notifications</a></p>
<p><a class="ctools-use-modal stop" href="/emmerich/unsubscribe/email-popup/js">Stop E-mail Notifications</a></p>
<p><a class="ctools-use-modal start" href="/emmerich/subscribe/mobile/js">Start Mobile Notifications</a></p>
<p><a class="ctools-use-modal stop" href="/emmerich/unsubscribe/mobile/js">Stop Mobile Notifications</a></p>  </div>

</div></div> <div id="block-simpleads-ad-groups-148" class="block block-simpleads"><div class="block-inner">

	     
  <div class="content">
		<div class="header">
  <div class="ad-link"></div>
</div>
<div class="adslist">
  <script type="text/javascript">
    _simpelads_load('.simpleads-148', 148, 1);
  </script>
    <div class="simpleads-148"></div>

    
</div>
  </div>

</div></div> <div id="block-block-40" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='74447' zone-alias='yaz_middle_1_skyscraper_medium_rectangle'></broadstreet-zone>
  </div>

</div></div> <div id="block-block-41" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='75048' zone-alias='yaz_middle_2_skyscraper_medium_rectangle'></broadstreet-zone>
  </div>

</div></div> <div id="block-block-42" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='74453' zone-alias='yaz_middle_3_skyscraper_medium_rectangle'></broadstreet-zone>
  </div>

</div></div> <div id="block-block-43" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='75115' zone-alias='yaz_middle_4_skyscraper_medium_rectangle'></broadstreet-zone>
  </div>

</div></div> <div id="block-block-44" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='75672' zone-alias='yaz_middle_5_skyscraper_medium_rectangle'></broadstreet-zone>
  </div>

</div></div> <div id="block-block-38" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		 <p style="text-align: center;"><a href="/most-read"><img alt="" class="media-image" height="576" style="width: 300px; height: 400px;" width="432" src="//www.yazooherald.net/sites/default/files/styles/large/public/Most-Read-Stories_3.jpg?itok=doq9Pp2i" /></a></p>
   </div>

</div></div> <div id="block-block-45" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='74455' zone-alias='yaz_middle_6_skyscraper_medium_rectangle'></broadstreet-zone>
  </div>

</div></div> <div id="block-block-46" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='74444' zone-alias='yaz_bottom_skyscraper_medium_rectangle'></broadstreet-zone>
  </div>

</div></div>   </div>
              <div class="region region-sidebar-second">
    <div id="block-fb-likebox-0" class="block block-fb-likebox adServeMargin"><div class="block-inner">

	     
  <div class="content">
		<div class="fb-page" data-href="https://www.facebook.com/yazooherald" data-width="300" data-height="500" data-tabs="timeline" data-hide-cover="0" data-show-facepile="1" data-hide-cta="0" data-small-header="0" data-adapt-container-width="1"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/yazooherald"><a href="https://www.facebook.com/yazooherald"><span>Like us on Facebook</span></a></blockquote></div></div>  </div>

</div></div>   </div>
  
          </div>              
        </aside>
             
      </div>            
  
    </section>
  </div></div>
  
    
    <div class="preface-wrapper"><div class="preface-wrapper-inner container_12">  
      <section id="preface" class="clearfix">
        <div class="grid_6">  <div class="region region-preface-1">
    <div id="block-block-47" class="block block-block adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='74458' zone-alias='yaz_top_left_widget_medium_rectangle'></broadstreet-zone>
  </div>

</div></div> <div id="block-views-weddings-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>News</span></h3>
     
  <div class="content">
		<div class="view view-weddings view-id-weddings view-display-id-block view-dom-id-4a2814407b823903b4e6af192fa89329">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="/front-page-slideshow-news/greer-crowned-miss-tougaloo-college"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/1106tougaloo.jpg?itok=zlkdqsUs" width="100" height="63" alt="" /></span></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-news/greer-crowned-miss-tougaloo-college"><span>Greer crowned Miss Tougaloo College</span></a></span>  </div>  
  <div class="views-field views-field-body">        <span class="field-content"> Mallory E. Greer, of Yazoo City and the daughter of Susie Greer and the late Edward Greer, was... <a href="/front-page-slideshow-news/greer-crowned-miss-tougaloo-college" class="views-more-link"><span>READ MORE</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-weddings view-id-weddings view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/news/washington-named-president-yazoo-county-fair-civic-league"><span>Washington named president of the Yazoo County Fair &amp; Civic League</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/news/henry-brickell-memorial-service-be-held-nov-22" class="active"><span>Henry Brickell memorial service to be held on Nov. 22</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/news/special-election-ward-4-will-be-held-monday"><span>Special election for Ward 4 will be held Monday</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/news/shooting-suspect-remains-run"><span>Shooting suspect remains on the run</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/news/schools-score-below-average-k-readiness"><span>Schools score below average in K-readiness</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-block-48" class="block block-block adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='74456' zone-alias='yaz_middle_left_widget_medium_rectangle'></broadstreet-zone>
  </div>

</div></div> <div id="block-views-sports-recent-stories-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Sports</span></h3>
     
  <div class="content">
		<div class="view view-sports-recent-stories view-id-sports_recent_stories view-display-id-block view-dom-id-e9d026ff160b002d340d7327723ce7ef">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/sports/panthers-win-round-one"><span>Panthers win round one</span></a></span>  </div>  
  <div class="views-field views-field-body">        <span class="field-content"> Yazoo County overcame a sloppy game to defeat Southeast Lauderdale 27-20 and move on to the second... <a href="/sports/panthers-win-round-one" class="views-more-link"><span>READ MORE</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-sports-recent-stories view-id-sports_recent_stories view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-sports/mavericks-remain-unchallenged-after-60-win-over-kemper"><span>Mavericks remain unchallenged after 60-win over Kemper</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-sports/saxton-shoots"><span>Saxton Shoots</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/sports/strong-finishes-state-meet"><span>Strong finishes at State Meet</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-sports/panthers-power-past-cougars-73-63-win"><span>Panthers power past Cougars in 73-63 win</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/sports/chloe-edwards-nails-game-winning-three-pointer"><span>Chloe Edwards nails game-winning three-pointer</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-block-49" class="block block-block adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='74442' zone-alias='yaz_bottom_left_widget_medium_rectangle'></broadstreet-zone>
  </div>

</div></div> <div id="block-block-34" class="block block-block adServeMargin"><div class="block-inner">

	     
  <div class="content">
		<!--<script src='https://adsmopress.com/ads-state.php?u=235&s=4&d=MS' type='text/javascript'></script>-->  </div>

</div></div> <div id="block-block-50" class="block block-block adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='74459' zone-alias='yaz_top_right_widget_medium_rectangle'></broadstreet-zone>
  </div>

</div></div> <div id="block-views-obituaries-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Obituaries</span></h3>
     
  <div class="content">
		<div class="view view-obituaries view-id-obituaries view-display-id-block view-dom-id-b8689e2e5eebba3c84d3470bc4dd9a99">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/regina-browne-burns"><span>Regina Browne Burns</span></a></span>  </div>  
  <div class="views-field views-field-body">        <span class="field-content"> Regina Browne Burns, 86, of Yazoo City passed away Monday, November 11, 2019 at the Martha Coker... <a href="/obituaries/regina-browne-burns" class="views-more-link"><span>READ MORE</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-obituaries view-id-obituaries view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/rea-thomas-waters"><span>Rea Thomas Waters</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/jenell-roberts-cooper"><span>Jenell Roberts Cooper</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/roosevelt-bo-sack-stewart-0"><span>Roosevelt &quot;Bo Sack&quot; Stewart</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/wilva-yvonne-beets-tucker"><span>Wilva Yvonne Beets Tucker</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/opal-hilderbrand"><span>Opal Hilderbrand</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-block-51" class="block block-block adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='75665' zone-alias='yaz_middle_right_widget_medium_rectangle'></broadstreet-zone>
  </div>

</div></div>   </div>
</div>
        <div class="grid_6">  <div class="region region-preface-2">
    <div id="block-block-52" class="block block-block adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='74457' zone-alias='yaz_top_middle_widget_medium_rectangle'></broadstreet-zone>
  </div>

</div></div> <div id="block-views-business-top-stories-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Opinion:</span></h3>
     
  <div class="content">
		<div class="view view-business-top-stories view-id-business_top_stories view-display-id-block view-dom-id-3ee5d063e443a62ecb1d068cbbb8d42f">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="/opinion-columnists/its-always-those-dang-foxes"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/royce lott_7.jpg?itok=lIuTLw3P" width="100" height="62" alt="" /></span></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-columnists/its-always-those-dang-foxes"><span>It&#039;s always those dang foxes...</span></a></span>  </div>  
  <div class="views-field views-field-body">        <span class="field-content"> In the beautiful Song of Solomon, we often overlook that little verse in chapter two, which says... <a href="/opinion-columnists/its-always-those-dang-foxes" class="views-more-link"><span>READ MORE</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-business-top-stories view-id-business_top_stories view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-letters-editor/lets-all-come-together-and-save-yazoo"><span>Let&#039;s all come together and save Yazoo</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-columnists/smart-phones-dumb-kids"><span>Smart phones, dumb kids</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-columnists/willie-brown-was-also-great-field"><span>Willie Brown was also great off the field</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-columnists/mr-nelson-took-pride-his-work"><span>Mr. Nelson took pride in his work</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-columnists/great-pumpkin-returns-once-more"><span>The Great Pumpkin returns once more</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-block-53" class="block block-block adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='75709' zone-alias='yaz_middle_middle_widget_medium_rectangle'></broadstreet-zone>
  </div>

</div></div> <div id="block-views-social-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Lifestyles</span></h3>
     
  <div class="content">
		<div class="view view-social view-id-social view-display-id-block view-dom-id-25c8161c5477ae5a06a550166e10480b">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="/lifestyles/miss-mohamed-wed-mccaleb"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/1106mohamed.jpg?itok=GX1uMewE" width="100" height="66" alt="" /></span></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/lifestyles/miss-mohamed-wed-mccaleb"><span>Miss Mohamed to wed McCaleb</span></a></span>  </div>  
  <div class="views-field views-field-body">        <span class="field-content"> Mr. and Mrs. Joseph Asim Mohamed II of Yazoo City, Mississippi announce the engagement of their... <a href="/lifestyles/miss-mohamed-wed-mccaleb" class="views-more-link"><span>READ MORE</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-social view-id-social view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/lifestyles/josh-miller-graduates-msu-thad-cochran-ag-leadership-program"><span>Josh Miller graduates from MSU Thad Cochran Ag Leadership Program</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-lifestyles/ma-spelling-bee-winners"><span>MA Spelling Bee winners</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/lifestyles/breast-cancer-awareness-drive"><span>Breast Cancer Awareness Drive</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/lifestyles/state-farm-donates-fire-prevention-kit-yazoo-city-fire-department"><span>State Farm donates Fire Prevention Kit to Yazoo City Fire Department</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-lifestyles/benton-academy-students-attend-msais-convention"><span>Benton Academy students attend MSAIS Convention</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-block-54" class="block block-block adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='74445' zone-alias='yaz_bottom_middle_widget_medium_rectangle'></broadstreet-zone>
  </div>

</div></div> <div id="block-quicktabs-most-read-headline" class="block block-quicktabs"><div class="block-inner">

	      <h3 class="title"><span>Most Read - Headline</span></h3>
     
  <div class="content">
		<div  id="quicktabs-most_read_headline" class="quicktabs-wrapper quicktabs-style-nostyle"><div class="item-list"><ul class="quicktabs-tabs quicktabs-style-nostyle"><li class="active first"><a href="/news/henry-brickell-memorial-service-be-held-nov-22?qt-most_read_headline=0#qt-most_read_headline" id="quicktabs-tab-most_read_headline-0" class="active"><span>Week</span></a></li>
<li><a href="/news/henry-brickell-memorial-service-be-held-nov-22?qt-most_read_headline=1#qt-most_read_headline" id="quicktabs-tab-most_read_headline-1" class="active"><span>Month</span></a></li>
<li><a href="/news/henry-brickell-memorial-service-be-held-nov-22?qt-most_read_headline=2#qt-most_read_headline" id="quicktabs-tab-most_read_headline-2" class="active"><span>Year</span></a></li>
<li class="last"><a href="/news/henry-brickell-memorial-service-be-held-nov-22?qt-most_read_headline=3#qt-most_read_headline" id="quicktabs-tab-most_read_headline-3" class="active"><span>All Time</span></a></li>
</ul></div><div id="quicktabs-container-most_read_headline" class="quicktabs_main quicktabs-style-nostyle"><div  id="quicktabs-tabpage-most_read_headline-0" class="quicktabs-tabpage "><div class="view view-most-read-headline view-id-most_read_headline view-display-id-block_1 view-dom-id-f9b74ffc8ceb3f9349ce3fd738323627">
        
  
  
      <div class="view-content">
      
  
  
  <div class="views-row views-row-1 views-row-odd views-row-first">
    <div class="views-field views-field-field-image"><div class="field-content"><a href="/front-page-slideshow-news/too-shall-pass-moore-describes-battle-rare-brain-disorder"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/1113moore.jpg?itok=uvRYN14t" width="100" height="64" alt="" /></span></a></div></div><div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/too-shall-pass-moore-describes-battle-rare-brain-disorder?most_read_source=week"><span>This too shall pass: Moore describes battle with rare brain disorder</span></a></span></div>  </div>
  
      <div class="attachment">
  
  <div class="views-row views-row-2 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/deputies-searching-yazoos-most-wanted-after-chase-anding-oil-city-road?most_read_source=week"><span>Deputies searching for Yazoo&#039;s Most Wanted after chase on Anding-Oil City Road</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-3 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/obituaries/rea-thomas-waters?most_read_source=week"><span>Rea Thomas Waters</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-4 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/opinion-letters-editor/lets-all-come-together-and-save-yazoo?most_read_source=week"><span>Let&#039;s all come together and save Yazoo</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-5 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/news/operation-christmas-child-returns-yazoo-0?most_read_source=week"><span>Operation Christmas Child returns to Yazoo</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-6 views-row-even views-row-last">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/portrait-american-hero-remembering-late-griffin-norquist-sr?most_read_source=week"><span>Portrait of an American Hero: Remembering the late Griffin Norquist Sr.</span></a></span></div>  </div>

</div>
    </div>
  
      <h2 class="element-invisible">Pages</h2><div class="item-list"><ul class="pager"><li class="pager-current first">1</li>
<li class="pager-item"><a title="Go to page 2" href="/news/henry-brickell-memorial-service-be-held-nov-22?page=0%2C0%2C1">2</a></li>
<li class="pager-item"><a title="Go to page 3" href="/news/henry-brickell-memorial-service-be-held-nov-22?page=0%2C0%2C2">3</a></li>
<li class="pager-ellipsis">…</li>
<li class="pager-next"><a title="Go to next page" href="/news/henry-brickell-memorial-service-be-held-nov-22?page=0%2C0%2C1">next ›</a></li>
<li class="pager-last last"><a title="Go to last page" href="/news/henry-brickell-memorial-service-be-held-nov-22?page=0%2C0%2C5">last »</a></li>
</ul></div>  
  
  
  
  
</div></div><div  id="quicktabs-tabpage-most_read_headline-1" class="quicktabs-tabpage quicktabs-hide"><div class="view view-most-read-headline view-id-most_read_headline view-display-id-block_2 view-dom-id-efba8d29afee03dfb8753214a835f7b9">
        
  
  
      <div class="view-content">
      
  
  
  <div class="views-row views-row-1 views-row-odd views-row-first">
    <div class="views-field views-field-field-image"><div class="field-content"><a href="/obituaries/roosevelt-bo-sack-stewart"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/bo sack.jpg?itok=wcW17BMN" width="100" height="62" alt="" /></span></a></div></div><div class="views-field views-field-title"><span class="field-content"><a href="/obituaries/roosevelt-bo-sack-stewart?most_read_source=month"><span>Roosevelt &quot;Bo Sack&quot; Stewart</span></a></span></div>  </div>
  
      <div class="attachment">
  
  <div class="views-row views-row-2 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/police-chief-responds-weekend-violence?most_read_source=month"><span>Police chief responds to weekend violence</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-3 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/charles-o-nelson?most_read_source=month"><span>Charles O. Nelson</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-4 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/too-shall-pass-moore-describes-battle-rare-brain-disorder?most_read_source=month"><span>This too shall pass: Moore describes battle with rare brain disorder</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-5 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/obituaries/william-%E2%80%9Cbilly%E2%80%9D-worthy-jr?most_read_source=month"><span>William “Billy” Worthy Jr. </span></a></span></div>  </div>
  
  
  <div class="views-row views-row-6 views-row-even views-row-last">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/deputies-searching-yazoos-most-wanted-after-chase-anding-oil-city-road?most_read_source=month"><span>Deputies searching for Yazoo&#039;s Most Wanted after chase on Anding-Oil City Road</span></a></span></div>  </div>

</div>
    </div>
  
      <h2 class="element-invisible">Pages</h2><div class="item-list"><ul class="pager"><li class="pager-current first">1</li>
<li class="pager-item"><a title="Go to page 2" href="/news/henry-brickell-memorial-service-be-held-nov-22?page=0%2C0%2C1">2</a></li>
<li class="pager-item"><a title="Go to page 3" href="/news/henry-brickell-memorial-service-be-held-nov-22?page=0%2C0%2C2">3</a></li>
<li class="pager-ellipsis">…</li>
<li class="pager-next"><a title="Go to next page" href="/news/henry-brickell-memorial-service-be-held-nov-22?page=0%2C0%2C1">next ›</a></li>
<li class="pager-last last"><a title="Go to last page" href="/news/henry-brickell-memorial-service-be-held-nov-22?page=0%2C0%2C15">last »</a></li>
</ul></div>  
  
  
  
  
</div></div><div  id="quicktabs-tabpage-most_read_headline-2" class="quicktabs-tabpage quicktabs-hide"><div class="view view-most-read-headline view-id-most_read_headline view-display-id-block view-dom-id-a52d4127956e95fcb45b023bb28905b4">
        
  
  
      <div class="view-content">
      
  
  
  <div class="views-row views-row-1 views-row-odd views-row-first">
    <div class="views-field views-field-field-image"><div class="field-content"><a href="/sports/lady-panthers-finish-strong-track-season"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/0522track.jpg?itok=HfROJN-j" width="100" height="64" alt="" /></span></a></div></div><div class="views-field views-field-title"><span class="field-content"><a href="/sports/lady-panthers-finish-strong-track-season?most_read_source=year"><span>Lady Panthers finish strong track season</span></a></span></div>  </div>
  
      <div class="attachment">
  
  <div class="views-row views-row-2 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/obituaries/joyce-b-davis?most_read_source=year"><span>Joyce B. Davis</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-3 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/news/yazoo-county-school-district-adding-three-new-sports-opportunities?most_read_source=year"><span>Yazoo County School District adding three new sports opportunities</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-4 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/simmons-bids-farewell?most_read_source=year"><span>Simmons bids farewell</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-5 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/news/eleven-candidates-have-qualified-local-elections?most_read_source=year"><span>Eleven candidates have qualified for local elections</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-6 views-row-even views-row-last">
    <div class="views-field views-field-title"><span class="field-content"><a href="/news/suspect-arrested-benton-armed-robbery?most_read_source=year"><span>Suspect arrested in Benton armed robbery</span></a></span></div>  </div>

</div>
    </div>
  
      <h2 class="element-invisible">Pages</h2><div class="item-list"><ul class="pager"><li class="pager-current first">1</li>
<li class="pager-item"><a title="Go to page 2" href="/news/henry-brickell-memorial-service-be-held-nov-22?page=1">2</a></li>
<li class="pager-item"><a title="Go to page 3" href="/news/henry-brickell-memorial-service-be-held-nov-22?page=2">3</a></li>
<li class="pager-ellipsis">…</li>
<li class="pager-next"><a title="Go to next page" href="/news/henry-brickell-memorial-service-be-held-nov-22?page=1">next ›</a></li>
<li class="pager-last last"><a title="Go to last page" href="/news/henry-brickell-memorial-service-be-held-nov-22?page=161">last »</a></li>
</ul></div>  
  
  
  
  
</div></div><div  id="quicktabs-tabpage-most_read_headline-3" class="quicktabs-tabpage quicktabs-hide"><div class="view view-most-read-headline view-id-most_read_headline view-display-id-block_3 view-dom-id-eca47dcefc3bea98b700b652e872eb6b">
        
  
  
      <div class="view-content">
      
  
  
  <div class="views-row views-row-1 views-row-odd views-row-first">
    <div class="views-field views-field-field-image"><div class="field-content"><a href="/front-page-slideshow-news/riding-after-dream"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/1231leiannwaters.jpg?itok=wYfxc7wP" width="100" height="75" alt="" /></span></a></div></div><div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/riding-after-dream?most_read_source=all"><span>Riding After a Dream</span></a></span></div>  </div>
  
      <div class="attachment">
  
  <div class="views-row views-row-2 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/crimm-completes-term-president?most_read_source=all"><span>Crimm completes term as president</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-3 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/obituaries/bill-beeson?most_read_source=all"><span>Bill Beeson</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-4 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/obituaries/albert-woodley-cook-jr?most_read_source=all"><span>Albert Woodley Cook Jr.</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-5 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/obituaries/shirley-summerlin?most_read_source=all"><span>Shirley Summerlin</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-6 views-row-even views-row-last">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/moonlight-and-mistletoe?most_read_source=all"><span>Moonlight and Mistletoe</span></a></span></div>  </div>

</div>
    </div>
  
      <h2 class="element-invisible">Pages</h2><div class="item-list"><ul class="pager"><li class="pager-current first">1</li>
<li class="pager-item"><a title="Go to page 2" href="/news/henry-brickell-memorial-service-be-held-nov-22?page=0%2C0%2C0%2C1">2</a></li>
<li class="pager-item"><a title="Go to page 3" href="/news/henry-brickell-memorial-service-be-held-nov-22?page=0%2C0%2C0%2C2">3</a></li>
<li class="pager-ellipsis">…</li>
<li class="pager-next"><a title="Go to next page" href="/news/henry-brickell-memorial-service-be-held-nov-22?page=0%2C0%2C0%2C1">next ›</a></li>
<li class="pager-last last"><a title="Go to last page" href="/news/henry-brickell-memorial-service-be-held-nov-22?page=0%2C0%2C0%2C800">last »</a></li>
</ul></div>  
  
  
  
  
</div></div></div></div>  </div>

</div></div> <div id="block-block-55" class="block block-block adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='74446' zone-alias='yaz_bottom_right_widget_medium_rectangle'></broadstreet-zone>
  </div>

</div></div>   </div>
</div>
        <div class="grid_0"></div>
        <div class="grid_0"></div>
      </section>
          </div></div>  
     
   
    
<!-- All Hail the Footer -->
  <div class="footer-wrapper"><div class="footer-wrapper-inner container_12">
    <footer id="footer" class="grid_12 clearfix">
        <div class="region region-footer">
    <div id="block-block-70" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id='75102' zone-alias='yaz_footer_leaderboard'></broadstreet-zone>
  </div>

</div></div> <div id="block-block-3" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		 <p style="text-align: center;"><span style="font-size:11px;">Copyright 2015 • The Yazoo Herald • 1035 Grand Ave. • Yazoo City, MS 39194 • (662) 746-4911</span></p>
<p style="text-align: center;"><span style="font-size:11px;">Emmerich Newspapers proudly serve the following Mississippi communities:</span></p>
<p style="font-size: 13.008px; text-align: center;"><strong><span style="font-size: 11px;"><span style="line-height: 1.538em;">ACKERMAN • <a href="http://winonatimes.com/" target="_blank">CARROLLTON</a> • <a href="http://tallahatchienews.ms" target="_blank">CHARLESTON</a> • CLARKSDALE • <a href="http://columbianprogress.com" target="_blank">COLUMBIA</a> • EUPORA • <a href="http://sctonline.net" target="_blank">FOREST</a> • <a href="http://ddtonline.com" target="_blank">GREENVILLE</a> • <a href="http://gwcommonwealth.com" target="_blank">GREENWOOD</a> • <a href="http://HubCitySPOKES.com" target="_blank">HATTIESBURG</a></span><br /><span style="line-height: 1.538em;"><a href="http://northsidesun.com" target="_blank">JACKSON</a> • <a href="http://starherald.net" target="_blank">KOSCIUSKO</a> • <a href="http://enterprise-tocsin.com" target="_blank">INDIANOLA</a> • <a href="http://thechronicle.ms" target="_blank">LAUREL</a> • LOUISVILLE • <a href="http://simpsoncounty.ms" target="_blank">MAGEE</a> • <a href="http://simpsoncounty.ms" target="_blank">MENDENHALL</a> • <a href="http://enterprise-journal.com" target="_blank">McCOMB</a> • <a href="http://newtoncountyappeal.com" target="_blank">NEWTON</a> • <a href="http://HubCitySPOKES.com" target="_blank">PETAL</a> • <a href="http://clarkecountytrib.com" target="_blank">QUITMAN</a> • <a href="http://winonatimes.com/" target="_blank">WINONA</a> • <a href="http://yazooherald.net" target="_blank">YAZOO CITY</a></span></span></strong></p>
<p style="font-size: 13.008px; text-align: center;"><strong><span style="font-size: 11px;">As well as the following communities: DUMAS, Ark., <a href="http://madisonjournal.com" target="_blank">TALLULAH, La.</a>, and FRANKLINTON, La.</span></strong></p>
<p style="text-align: center;"><span style="font-size:11px;"><em>For more information on how to extend your advertising message to these communities, <a href="/emmerich-contact-form">click here.</a></em></span></p>
   </div>

</div></div>   </div>
      
    </footer><!-- /footer -->
  </div></div>
 
</div><!-- page -->  <script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/addthis/addthis.js?q0npcl"></script>
</body>

</html>