<!DOCTYPE html>
<html lang="en" dir="ltr" >

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="/obituaries/irene-street" />
<link rel="shortlink" href="/node/4751" />
<meta property="og:type" content="Article" /><meta property="og:title" content="Irene Street"/><meta property="og:url" content="https://www.yazooherald.net/obituaries/irene-street"/><meta property="og:image" content="//www.yazooherald.net/sites/default/files/TheYazooHeraldWebLogo2.png"/><meta property="fb:admins" content="dgustoughson"><link rel="shortcut icon" href="//www.yazooherald.net/sites/default/files/yazoo-favicon_2.jpg" type="image/jpeg" />
<link rel="apple-touch-icon" href="//www.yazooherald.net/sites/default/files/yazoo-favicon_1.jpg" type="image/jpeg" />
  <title>Irene Street | The Yazoo Herald</title>  
  <style type="text/css" media="all">
@import url("//www.yazooherald.net/modules/system/system.base.css?pn9nqr");
@import url("//www.yazooherald.net/modules/system/system.menus.css?pn9nqr");
@import url("//www.yazooherald.net/modules/system/system.messages.css?pn9nqr");
@import url("//www.yazooherald.net/modules/system/system.theme.css?pn9nqr");
</style>
<style type="text/css" media="all">
@import url("//www.yazooherald.net/misc/ui/jquery.ui.core.css?pn9nqr");
@import url("//www.yazooherald.net/misc/ui/jquery.ui.theme.css?pn9nqr");
@import url("//www.yazooherald.net/misc/ui/jquery.ui.button.css?pn9nqr");
@import url("//www.yazooherald.net/misc/ui/jquery.ui.resizable.css?pn9nqr");
@import url("//www.yazooherald.net/misc/ui/jquery.ui.dialog.css?pn9nqr");
</style>
<style type="text/css" media="all">
@import url("//www.yazooherald.net/modules/aggregator/aggregator.css?pn9nqr");
@import url("//www.yazooherald.net/sites/all/modules/calendar/css/calendar_multiday.css?pn9nqr");
@import url("//www.yazooherald.net/sites/all/modules/date/date_api/date.css?pn9nqr");
@import url("//www.yazooherald.net/sites/all/modules/date/date_popup/themes/datepicker.1.7.css?pn9nqr");
@import url("//www.yazooherald.net/modules/field/theme/field.css?pn9nqr");
@import url("//www.yazooherald.net/modules/node/node.css?pn9nqr");
@import url("//www.yazooherald.net/modules/search/search.css?pn9nqr");
@import url("//www.yazooherald.net/sites/all/modules/simpleads/simpleads.css?pn9nqr");
@import url("//www.yazooherald.net/sites/all/modules/ubercart/uc_order/uc_order.css?pn9nqr");
@import url("//www.yazooherald.net/sites/all/modules/ubercart/uc_product/uc_product.css?pn9nqr");
@import url("//www.yazooherald.net/sites/all/modules/ubercart/uc_store/uc_store.css?pn9nqr");
@import url("//www.yazooherald.net/modules/user/user.css?pn9nqr");
@import url("//www.yazooherald.net/sites/all/modules/views/css/views.css?pn9nqr");
</style>
<style type="text/css" media="all">
@import url("//www.yazooherald.net/sites/all/modules/ed_classified/theme/classified.css?pn9nqr");
@import url("//www.yazooherald.net/sites/all/modules/ctools/css/ctools.css?pn9nqr");
@import url("//www.yazooherald.net/sites/all/modules/event_calendar/event_popup/css/event_popup.css?pn9nqr");
@import url("//www.yazooherald.net/sites/all/modules/quicktabs/css/quicktabs.css?pn9nqr");
</style>
<style type="text/css" media="all">
@import url("//www.yazooherald.net/sites/all/themes/bones/css/normalize.css?pn9nqr");
@import url("//www.yazooherald.net/sites/all/themes/bones/css/formalize.css?pn9nqr");
@import url("//www.yazooherald.net/sites/all/themes/bones/css/grid_12.css?pn9nqr");
@import url("//www.yazooherald.net/sites/all/themes/bones/css/layout.css?pn9nqr");
</style>
<style type="text/css" media="all">
@import url("//www.yazooherald.net/sites/all/themes/current/css/style4.css?pn9nqr");
@import url("//www.yazooherald.net/sites/all/themes/current/css/responsive.css?pn9nqr");
@import url("//www.yazooherald.net/sites/all/themes/current/css/custom.css?pn9nqr");
</style>
  <script type="text/javascript" src="//www.yazooherald.net/misc/jquery.js?v=1.4.4"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/jquery.once.js?v=1.2"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.slots = googletag.slots || {};
//--><!]]>
</script>
<script type="text/javascript" src="//www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/drupal.js?pn9nqr"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.core.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.widget.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.button.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.mouse.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.draggable.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.position.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.resizable.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.dialog.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/views/js/jquery.ui.dialog.patch.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/jquery.cookie.js?v=1.0"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/jquery.form.js?v=2.52"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ajax.js?v=7.64"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/simpleads/simpleads.js?pn9nqr"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/simpleads/modules/simpleads_campaigns/simpleads_campaigns.js?pn9nqr"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
googletag.cmd.push(function() {
  googletag.pubads().enableAsyncRendering();
  googletag.pubads().enableSingleRequest();
  googletag.pubads().collapseEmptyDivs();
});

googletag.enableServices();
//--><!]]>
</script>
<script type="text/javascript" src="//www.yazooherald.net/misc/progress.js?pn9nqr"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/event_calendar/event_popup/js/event_popup.js?pn9nqr"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/event_calendar/event_popup/js/event_popup_validate.js?pn9nqr"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery(document).ready(function($) { 
    $.expr[':'].regex = function(elem, index, match) {
            var matchParams = match[3].split(','),
            validLabels = /^(data|css):/,
            attr = {
                method: matchParams[0].match(validLabels) ? 
                matchParams[0].split(':')[0] : 'attr',
                property: matchParams.shift().replace(validLabels,'')
            },
            regexFlags = 'ig',
            regex = new RegExp(matchParams.join('').replace(/^\s+|\s+$/g,''), regexFlags);
            return regex.test(jQuery(elem)[attr.method](attr.property));
        }
    });
//--><!]]>
</script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/views/js/base.js?pn9nqr"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var switchTo5x = true;var useFastShare = true;
//--><!]]>
</script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/views/js/ajax_view.js?pn9nqr"></script>
<script type="text/javascript" src="https://ws.sharethis.com/button/buttons.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (typeof stLight !== 'undefined') { stLight.options({"publisher":"fc937732-3d58-4754-8720-1d210502838c","version":"5x","doNotCopy":false,"hashAddressBar":true,"doNotHash":false,"onhover":false,"newOrZero":"zero","lang":"en"}); }
//--><!]]>
</script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/google_analytics/googleanalytics.js?pn9nqr"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","//www.google-analytics.com/analytics.js","ga");ga("create", "UA-75225316-16", {"cookieDomain":"auto"});ga("set", "anonymizeIp", true);ga("send", "pageview");
//--><!]]>
</script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/fb_likebox/fb_likebox.js?pn9nqr"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/quicktabs/js/quicktabs.js?pn9nqr"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/bones/js/jquery.formalize.min.js?pn9nqr"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/bones/js/superfish.js?pn9nqr"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/current/js/scripts.js?pn9nqr"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/bones/js/jquery.easing.1.3.js?pn9nqr"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/bones/js/jquery.equal-height-columns.js?pn9nqr"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/current/js/jquery.mobilemenu.min.js?pn9nqr"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/current/js/jquery.color.js?pn9nqr"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/current/js/jquery-glowing.js?pn9nqr"></script>
<script type="text/javascript">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</script>
  <meta name="viewport" content="width=device-width, initial-scale=1">  
  <!--[if lt IE 9]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
  <link href='//fonts.googleapis.com/css?family=Paytone+One' rel='stylesheet' type='text/css'>
  <script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-8039211595423832",
    enable_page_level_ads: true
  });
</script>

</head>

<body class="html not-front not-logged-in one-sidebar sidebar-second page-node page-node- page-node-4751 node-type-article sidebars-split obituaries irene-street">
  <div id="skip-link">
    <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    <div id="page">

  <div class="user-menu-wrapper"><div class="user-menu-wrapper-inner container_12">  
    <nav id="user-menu" class="grid_12 clearfix">
        <div class="region region-user-menu">
    <div id="block-system-user-menu" class="block block-system block-menu"><div class="block-inner">

	      <h3 class="title"><span>User menu</span></h3>
     
  <div class="content">
		<ul class="menu"><li class="first last leaf"><a href="/user/login" title=""><span>Login</span></a></li>
</ul>  </div>

</div></div>   </div>
        <div class="region region-search-box">
    <div id="block-search-form" class="block block-search"><div class="block-inner">

	     
  <div class="content">
		<form onsubmit="if(this.search_block_form.value==&#039;Search&#039;){ alert(&#039;Please enter a search&#039;); return false; }" action="/obituaries/irene-street" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." onblur="if (this.value == &#039;&#039;) {this.value = &#039;Search&#039;;}" onfocus="if (this.value == &#039;Search&#039;) {this.value = &#039;&#039;;}" type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-4cWU8fV4nXapWqbyfESBDQHxXvPoGLJI9Md__xYkkyI" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form>  </div>

</div></div>   </div>
      <div id="social">
        <ul class="social-links">
          <li><a class="rss" href="/rss.xml"></a></li>
          <li><a class="twitter" href="http://www.twitter.com"></a></li>
          <li><a class="facebook" href="http://www.facebook.com"></a></li>
        </ul>
      </div>         
    </nav>
  </div></div>

  <div class="header-wrapper"><div class="header-wrapper-inner container_12">
    <header class="grid_12 clearfix">
            <div class="logo-slogan">  
        
                  <div class="site-logo">
            <a href="/"><img src="//www.yazooherald.net/sites/default/files/TheYazooHeraldWebLogo2.png" alt="" /></a>
          </div>
        	      
        
        <hgroup>
        
                    
                     
        
        </hgroup> 
  
      </div>

           
    </header>  
    
  </div></div>

      
    <div class="main-menu-wrapper"><div class="main-menu-wrapper-inner container_12">  
      <nav id="main-menu" class="grid_12 clearfix">
          <div class="region region-main-menu">
    <div id="block-system-main-menu" class="block block-system block-menu"><div class="block-inner">

	      <h3 class="title"><span>Main menu</span></h3>
     
  <div class="content">
		<ul class="menu"><li class="first expanded"><a href="/" title="Home"><span>Home</span></a><ul class="menu"><li class="first leaf"><a href="/about-us"><span>About Us</span></a></li>
<li class="leaf"><a href="/our-staff" title="Our Staff"><span>Our Staff</span></a></li>
<li class="leaf"><a href="/faqs" title="FAQ&#039;s"><span>FAQ&#039;s</span></a></li>
<li class="last leaf"><a href="/contact-us" title="Contact Us"><span>Contact Us</span></a></li>
</ul></li>
<li class="leaf"><a href="http://yazooherald.net/eedition-front" title=""><span>E-Edition</span></a></li>
<li class="leaf"><a href="/obituaries" title="Obituaries"><span>Obituaries</span></a></li>
<li class="leaf"><a href="/taxonomy/term/4" title="Sports"><span>Sports</span></a></li>
<li class="expanded"><a href="/opinion" title="Opinion"><span>Opinion</span></a><ul class="menu"><li class="first leaf"><a href="/columnists" title="Columnists"><span>Columnists</span></a></li>
<li class="leaf"><a href="/editorials" title="Editorials"><span>Editorials</span></a></li>
<li class="last leaf"><a href="/letters-editor" title="Letters to the Editor"><span>Letters to the Editor</span></a></li>
</ul></li>
<li class="expanded"><a href="/classified" title=""><span>Advertising</span></a><ul class="menu"><li class="first leaf"><a href="/classified/75" title=""><span>Legal Notices</span></a></li>
<li class="leaf"><a href="/newspaper-rates"><span>Newspaper Rates</span></a></li>
<li class="leaf"><a href="http://yazooherald.net/place-classified-ad-1" title=""><span>Place a Classified Ad</span></a></li>
<li class="last leaf"><a href="/website-rates"><span>Website Rates</span></a></li>
</ul></li>
<li class="expanded"><a href="/subscribe"><span>Subscribe</span></a><ul class="menu"><li class="first last leaf"><a href="/yazoo-herald"><span>The Yazoo Herald</span></a></li>
</ul></li>
<li class="last collapsed"><a href="/news"><span>News</span></a></li>
</ul>  </div>

</div></div>   </div>
      </nav>
    </div></div> 
      
  
  <div class="main-menu-second-level-wrapper clearfix"><div class="main-menu-second-level-wrapper-inner container_12">  
    <nav id="main-menu-second-level" class="grid_12">
            
    </nav>
  </div></div> 
  
<!-- Main Content -->  
  <div class="main-content-wrapper"><div class="main-content-wrapper-inner container_12">
    <section id="main-content" class="clearfix"> 	   

          
    
      <div class="main">
        <div class="main-inner  grid_8">
                    
	      
        
                                          
            <div class="region region-content-top">
    <div id="block-dfp-yaz-top-leaderboard" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_top_leaderboard-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_top_leaderboard&sz=600x500&c=17090">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_top_leaderboard&sz=600x500&c=17090">
</a>
</div>  </div>

</div></div>   </div>
                                          <div class="region region-content">
    <div id="block-system-main" class="block block-system"><div class="block-inner">

	     
  <div class="content">
		<article id="node-4751" class="node node-article node-promoted last clearfix">



  


  


  <div class="node-content-wrapper">



    


      


      
       <h1 class="title">Irene Street</h1>

      


    


    


    
        <ul class="links inline"><li class="statistics_counter first last"><span>108 reads</span></li>
</ul>
    


    
      <div class="submitted">

            <span class="date">Thu, 04/18/2019 - 12:45pm</span>

      </div>

    


    <div class="content">

    <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even"> <p>On Wednesday, April 17, 2019, Alice Irene Fredrick Street, of Flora, Mississippi, passed away at the age of 95.</p>
<p>Irene Street was born on January 1, 1924, in Benton, Mississippi to Lillie Elmore Fredrick and Rufus Willis Fredrick.  She married David Lovest Street on January 3rd, 1943, and raised four children (Lynda Irene, Willis Benjamin, Robert Grady, and Marianne) in small community of Eden, Mississippi. In Eden, she was a Sunday School Teacher and faithful member of Eden Baptist Church for over 40 years. Irene was an athlete, a homemaker, a gardener, a writer, a baker, and wonderful mother and grandmother to her family.</p>
<p>In 1994, Irene and her husband moved to Flora, Mississippi, and became members of the Flora Baptist Church.  In Flora, she continued her faithful service and love for her church, her community, and her family. Her home welcomed anyone who needed a delicious meal, a cup of coffee, or a tea party. She was an example of unconditional love and the best grandmother to over 30 grandchildren, great-grandchildren, and great-great grandchildren.</p>
<p>She was preceded in death by her husband of 62 years, David Lovest Street, and an infant son, David Lovest Street Jr. She is survived by her four children and their spouses, Lynda (Robert) Breithaupt of Flora, Benny (Dawn) Street of Canton, Robert (Denice) Street of Brandon and Marianne Brackin of Flora; her sisters, Louise Villarossa (Dahlonega, Georgia), Patricia Street (Yazoo City, Mississippi) and Nell Little (Puckett, Mississippi) and numerous grandchildren.</p>
<p>The funeral services for Alice Irene Street are schedule for April 20, 2019 at Flora Baptist Church in Flora, Mississippi. Visitation will begin at 12:30 p.m. and the funeral service will begin at 2 p.m. Please join us as we celebrate her life during her favorite time of the year, Easter.</p>
<p>The family has entrusted Stricklin-King Funeral Home of Yazoo City with the arrangements.</p>
<p> </p><div class="ad">
        <div class="left"><div id="block-dfp-9b800b9bf1a6c91698aa78c8a7cffe14" class="block block-dfp adServeMargin"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_top_left_in_story_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_top_left_in-story_medium_rectangle&sz=600x500&c=39192">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_top_left_in-story_medium_rectangle&sz=600x500&c=39192">
</a>
</div>  </div>

</div></div> </div>
        </div>
 </div></div></div><div class="item-list"><ul class="pager-for-content-type flippy"><li class="pager-previous prev first last"><a href="/front-page-slideshow-sports/shelton-wins-state-powerlifting-title" class="prev"><span>‹ Previous</span></a></li>
</ul></div>
    </div>







    
      <nav class="taxonomy"><div class="taxonomy-inner clearfix">

        
      </div></nav>

    


  
      <nav class="taxonomy"><div class="taxonomy-inner clearfix">

        
      </div></nav>

    


 






  </div>





</article>




  </div>

</div></div> <div id="block-sharethis-sharethis-block" class="block block-sharethis"><div class="block-inner">

	     
  <div class="content">
		<div class="sharethis-wrapper"><span st_url="https://www.yazooherald.net/obituaries/irene-street" st_title="Irene Street" class="st_facebook_button" displayText="facebook"></span>
<span st_url="https://www.yazooherald.net/obituaries/irene-street" st_title="Irene Street" class="st_twitter_button" displayText="twitter" st_via="" st_username=""></span>
<span st_url="https://www.yazooherald.net/obituaries/irene-street" st_title="Irene Street" class="st_pinterest_button" displayText="pinterest" st_via="" st_username=""></span>
<span st_url="https://www.yazooherald.net/obituaries/irene-street" st_title="Irene Street" class="st_tumblr_button" displayText="tumblr" st_via="" st_username=""></span>
<span st_url="https://www.yazooherald.net/obituaries/irene-street" st_title="Irene Street" class="st_email_button" displayText="email" st_via="" st_username=""></span>
<span st_url="https://www.yazooherald.net/obituaries/irene-street" st_title="Irene Street" class="st_fblike_button" displayText="fblike" st_via="" st_username=""></span>
</div>  </div>

</div></div> <div id="block-facebook-comments-box-facebook-comments-box" class="block block-facebook-comments-box"><div class="block-inner">

	     
  <div class="content">
		<div class="facebook-comments-box"><div id="fb-root"></div><script src="http://connect.facebook.net/en_US/all.js#xfbml=1"></script><fb:comments href="https://www.yazooherald.net/obituaries/irene-street"  num_posts="10"  width="580"  colorscheme="light" ></fb:comments></div>  </div>

</div></div> <div id="block-dfp-yaz-medium-leaderboard" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_medium_leaderboard-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_medium_leaderboard&sz=600x500&c=77680">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_medium_leaderboard&sz=600x500&c=77680">
</a>
</div>  </div>

</div></div>   </div>
  
                  
                            </div> 
                <aside class="sidebar second-sidebar grid_4">
              <div class="region region-second-ad">
    <div id="block-simpleads-ad-groups-148" class="block block-simpleads"><div class="block-inner">

	     
  <div class="content">
		<div class="header">
  <div class="ad-link"></div>
</div>
<div class="adslist">
  <script type="text/javascript">
    _simpelads_load('.simpleads-148', 148, 1);
  </script>
    <div class="simpleads-148"></div>

    
</div>
  </div>

</div></div> <div id="block-dfp-1274a596e817b07731a6dd25e59304b9" class="block block-dfp"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_middle_1_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_middle_1_skyscraper_medium_rectangle&sz=600x500&c=83395">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_middle_1_skyscraper_medium_rectangle&sz=600x500&c=83395">
</a>
</div>  </div>

</div></div> <div id="block-dfp-811705d3a59b91b8c7f39a799e6db3d2" class="block block-dfp"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_middle_2_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_middle_2_skyscraper_medium_rectangle&sz=600x500&c=22974">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_middle_2_skyscraper_medium_rectangle&sz=600x500&c=22974">
</a>
</div>  </div>

</div></div> <div id="block-dfp-7a6379ada523077fb90dad055db25fcd" class="block block-dfp"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_middle_3_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_middle_3_skyscraper_medium_rectangle&sz=600x500&c=22048">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_middle_3_skyscraper_medium_rectangle&sz=600x500&c=22048">
</a>
</div>  </div>

</div></div> <div id="block-dfp-d553375fd438aac474d494703dd8cbcf" class="block block-dfp"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_middle_4_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_middle_4_skyscraper_medium_rectangle&sz=600x500&c=90130">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_middle_4_skyscraper_medium_rectangle&sz=600x500&c=90130">
</a>
</div>  </div>

</div></div> <div id="block-dfp-cd27e71fcafc6df168fe3e8d3f26f55e" class="block block-dfp"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_middle_5_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_middle_5_skyscraper_medium_rectangle&sz=600x500&c=41561">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_middle_5_skyscraper_medium_rectangle&sz=600x500&c=41561">
</a>
</div>  </div>

</div></div> <div id="block-block-38" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		 <p style="text-align: center;"><a href="/most-read"><img alt="" class="media-image" height="576" style="width: 300px; height: 400px;" width="432" src="//www.yazooherald.net/sites/default/files/styles/large/public/Most-Read-Stories_3.jpg?itok=doq9Pp2i" /></a></p>
   </div>

</div></div> <div id="block-dfp-9359c0c7eebbe7338728ed2e38077cf2" class="block block-dfp"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_middle_6_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_middle_6_skyscraper_medium_rectangle&sz=600x500&c=89114">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_middle_6_skyscraper_medium_rectangle&sz=600x500&c=89114">
</a>
</div>  </div>

</div></div> <div id="block-dfp-4ff26d5a44d4cfa416af713791252845" class="block block-dfp"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_bottom_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_bottom_skyscraper_medium_rectangle&sz=600x500&c=88860">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_bottom_skyscraper_medium_rectangle&sz=600x500&c=88860">
</a>
</div>  </div>

</div></div>   </div>
              <div class="region region-sidebar-second">
    <div id="block-fb-likebox-0" class="block block-fb-likebox adServeMargin"><div class="block-inner">

	     
  <div class="content">
		<div class="fb-page" data-href="https://www.facebook.com/yazooherald" data-width="300" data-height="500" data-tabs="timeline" data-hide-cover="0" data-show-facepile="1" data-hide-cta="0" data-small-header="0" data-adapt-container-width="1"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/yazooherald"><a href="https://www.facebook.com/yazooherald"><span>Like us on Facebook</span></a></blockquote></div></div>  </div>

</div></div>   </div>
                
        </aside>
             
      </div>            
  
    </section>
  </div></div>
  
    
    <div class="preface-wrapper"><div class="preface-wrapper-inner container_12">  
      <section id="preface" class="clearfix">
        <div class="grid_4">  <div class="region region-preface-1">
    <div id="block-dfp-87fbf52277b8f3e22005a04574690781" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_top_left_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_top_left_widget_medium_rectangle&sz=600x500&c=14456">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_top_left_widget_medium_rectangle&sz=600x500&c=14456">
</a>
</div>  </div>

</div></div> <div id="block-views-weddings-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>News</span></h3>
     
  <div class="content">
		<div class="view view-weddings view-id-weddings view-display-id-block view-dom-id-678ee171dd149aa99926fca2e008cc19">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="/front-page-slideshow-news/two-tornadoes-hit-yazoo-county"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/0417storm front.jpg?itok=gcXgYu8e" width="100" height="67" alt="" /></span></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-news/two-tornadoes-hit-yazoo-county"><span>Two tornadoes hit Yazoo County</span></a></span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"> <p>Two tornadoes hit the southwestern portion of Yazoo County last weekend with residents... <a href="/front-page-slideshow-news/two-tornadoes-hit-yazoo-county" class="views-more-link"><span>READ MORE</span></a></div>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-weddings view-id-weddings view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/news/school-board-shocked-state-takeover"><span>School board shocked by state takeover</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/news/state-funds-are-coming-county-bridges"><span>State funds are coming for county bridges</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-news/passion-week-arrives-parkview"><span>Passion Week arrives at Parkview</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-news/yazoo-citys-freds-store-close"><span>Yazoo City&#039;s Fred&#039;s store to close</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-news-lifestyles/chamber-welcomes-cb-yazoo-business-community"><span>Chamber welcomes C&amp;B to Yazoo business community</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-dfp-3c05c49e0431377e33c85c006c823ec8" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_middle_left_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_middle_left_widget_medium_rectangle&sz=600x500&c=16220">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_middle_left_widget_medium_rectangle&sz=600x500&c=16220">
</a>
</div>  </div>

</div></div> <div id="block-views-sports-recent-stories-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Sports</span></h3>
     
  <div class="content">
		<div class="view view-sports-recent-stories view-id-sports_recent_stories view-display-id-block view-dom-id-0b93b75a7da56ee3b2d6e38ab790c4f3">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="/front-page-slideshow-sports/shelton-wins-state-powerlifting-title"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/0417champ.jpg?itok=84VvkYeF" width="100" height="68" alt="" /></span></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-sports/shelton-wins-state-powerlifting-title"><span>Shelton wins state powerlifting title</span></a></span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"> <p>Yazoo County’s Alzavian Shelton won a state title Saturday in the 275 weight class at the 3A... <a href="/front-page-slideshow-sports/shelton-wins-state-powerlifting-title" class="views-more-link"><span>READ MORE</span></a></div>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-sports-recent-stories view-id-sports_recent_stories view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-sports/panthers-win-second-straight-district-title"><span>Panthers win second straight district title</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/sports/ann-marie-jones-pitches-no-hitter-yazoo-county-against-mclaurin"><span>Ann Marie Jones pitches no hitter for Yazoo County against McLaurin</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/sports/ward-and-boggan-lead-ba-canton-academy-golf-tournament"><span>Ward and Boggan lead BA in Canton Academy golf tournament</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/sports/dent-has-impressive-showing-debut-ole-miss"><span>Dent has impressive showing in debut with Ole Miss</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/sports/indians-win-one-lose-one"><span>Indians win one, lose one</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-dfp-bbb6111ef381ac4528ed9ec51a11513d" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_bottom_left_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_bottom_left_widget_medium_rectangle&sz=600x500&c=65365">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_bottom_left_widget_medium_rectangle&sz=600x500&c=65365">
</a>
</div>  </div>

</div></div> <div id="block-block-34" class="block block-block adServeMargin"><div class="block-inner">

	     
  <div class="content">
		<!--<script src='https://adsmopress.com/ads-state.php?u=235&s=4&d=MS' type='text/javascript'></script>-->  </div>

</div></div>   </div>
</div>
        <div class="grid_4">  <div class="region region-preface-2">
    <div id="block-dfp-e151e0c8b83cc13e94ea635eca46f2a4" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_top_middle_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_top_middle_widget_medium_rectangle&sz=600x500&c=83236">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_top_middle_widget_medium_rectangle&sz=600x500&c=83236">
</a>
</div>  </div>

</div></div> <div id="block-views-business-top-stories-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Opinion:</span></h3>
     
  <div class="content">
		<div class="view view-business-top-stories view-id-business_top_stories view-display-id-block view-dom-id-83afd65cf6932c354aedd2759f1e69fe">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="/opinion-columnists/high-cost-lower-prices"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/jason patterson_7.jpg?itok=TgT8Hvw2" width="100" height="62" alt="" /></span></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-columnists/high-cost-lower-prices"><span>The high cost of lower prices</span></a></span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"> <p>Last week’s news that our local Fred’s store will be closing marks the end of 50 years of the... <a href="/opinion-columnists/high-cost-lower-prices" class="views-more-link"><span>READ MORE</span></a></div>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-business-top-stories view-id-business_top_stories view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-editorials/making-yazoo-city-safer-everyone"><span>Making Yazoo City safer for everyone</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-editorials/state-takeover-could-be-good-yazoos-youth"><span>State takeover could be good for Yazoo&#039;s youth</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-columnists/drawing-strength-failure"><span>Drawing strength from failure</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-columnists/haves-and-have-nots"><span>The haves and have nots</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-editorials/great-investment-yazoo-city"><span>A great investment in Yazoo City</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-dfp-3060d53de97465e1e01fc2e67a9fa96b" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_middle_middle_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_middle_middle_widget_medium_rectangle&sz=600x500&c=54590">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_middle_middle_widget_medium_rectangle&sz=600x500&c=54590">
</a>
</div>  </div>

</div></div> <div id="block-views-social-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Lifestyles</span></h3>
     
  <div class="content">
		<div class="view view-social view-id-social view-display-id-block view-dom-id-ea2ac1388c308035e390fb26e7ed9bfd">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="/front-page-slideshow-lifestyles/local-students-join-honor-society-holmes-cc"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/0417hccstudents.jpg?itok=VX84fJAV" width="100" height="67" alt="" /></span></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-lifestyles/local-students-join-honor-society-holmes-cc"><span>Local students join honor society at Holmes CC</span></a></span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"> <p>Yazoo County residents Josie Harris, Bruce Ruschewski and Sarah Hardy took part in the Phi... <a href="/front-page-slideshow-lifestyles/local-students-join-honor-society-holmes-cc" class="views-more-link"><span>READ MORE</span></a></div>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-social view-id-social view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/lifestyles/ellison-umc-youth-volunteer-manna-house"><span>Ellison UMC Youth volunteer at Manna House</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-news-lifestyles/chamber-welcomes-cb-yazoo-business-community"><span>Chamber welcomes C&amp;B to Yazoo business community</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/lifestyles/mills-details-upcoming-chamber-events"><span>Mills details upcoming Chamber events</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/lifestyles/barron-details-progress-county-schools"><span>Barron details progress at county schools</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/lifestyles/griffin-graduates-us-marine-corps-boot-camp"><span>Griffin graduates from US Marine Corps boot camp</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-dfp-6b8651675a962a883c58715d14e02ea5" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_bottom_middle_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_bottom_middle_widget_medium_rectangle&sz=600x500&c=10341">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_bottom_middle_widget_medium_rectangle&sz=600x500&c=10341">
</a>
</div>  </div>

</div></div>   </div>
</div>
        <div class="grid_4">  <div class="region region-preface-3">
    <div id="block-dfp-20020ae2463e841eb50a99d9f52eb769" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_top_right_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_top_right_widget_medium_rectangle&sz=600x500&c=37879">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_top_right_widget_medium_rectangle&sz=600x500&c=37879">
</a>
</div>  </div>

</div></div> <div id="block-views-obituaries-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Obituaries</span></h3>
     
  <div class="content">
		<div class="view view-obituaries view-id-obituaries view-display-id-block view-dom-id-cd7e978182556d6d45ddc7f8d9c2bd0b">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/irene-street" class="active"><span>Irene Street</span></a></span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"> <p>On Wednesday, April 17, 2019, Alice Irene Fredrick Street, of Flora, Mississippi, passed away... <a href="/obituaries/irene-street" class="views-more-link active"><span>READ MORE</span></a></div>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-obituaries view-id-obituaries view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/alvie-l-jenkins"><span>Alvie L. Jenkins</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/roy-stricklin"><span>Roy Stricklin</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/jean-hinkle"><span>Jean Hinkle</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/robert-berkley-simmons-iii"><span>Robert Berkley Simmons III</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/linda-lee-carson"><span>Linda Lee Carson</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-dfp-bf6f5f5865d744a4c5cff0637a56d6d0" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_middle_right_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_middle_right_widget_medium_rectangle&sz=600x500&c=92009">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_middle_right_widget_medium_rectangle&sz=600x500&c=92009">
</a>
</div>  </div>

</div></div> <div id="block-quicktabs-most-read-headline" class="block block-quicktabs"><div class="block-inner">

	      <h3 class="title"><span>Most Read - Headline</span></h3>
     
  <div class="content">
		<div  id="quicktabs-most_read_headline" class="quicktabs-wrapper quicktabs-style-nostyle"><div class="item-list"><ul class="quicktabs-tabs quicktabs-style-nostyle"><li class="active first"><a href="/obituaries/irene-street?qt-most_read_headline=0#qt-most_read_headline" id="quicktabs-tab-most_read_headline-0" class="active"><span>Week</span></a></li>
<li><a href="/obituaries/irene-street?qt-most_read_headline=1#qt-most_read_headline" id="quicktabs-tab-most_read_headline-1" class="active"><span>Month</span></a></li>
<li><a href="/obituaries/irene-street?qt-most_read_headline=2#qt-most_read_headline" id="quicktabs-tab-most_read_headline-2" class="active"><span>Year</span></a></li>
<li class="last"><a href="/obituaries/irene-street?qt-most_read_headline=3#qt-most_read_headline" id="quicktabs-tab-most_read_headline-3" class="active"><span>All Time</span></a></li>
</ul></div><div id="quicktabs-container-most_read_headline" class="quicktabs_main quicktabs-style-nostyle"><div  id="quicktabs-tabpage-most_read_headline-0" class="quicktabs-tabpage "><div class="view view-most-read-headline view-id-most_read_headline view-display-id-block_1 view-dom-id-3f7f2f76d5259904ec686bd8a9985a5a">
        
  
  
      <div class="view-content">
      
  
  
  <div class="views-row views-row-1 views-row-odd views-row-first">
    <div class="views-field views-field-field-image"><div class="field-content"></div></div><div class="views-field views-field-title"><span class="field-content"><a href="/news/natchez-man-killed-weekend-accident?most_read_source=week"><span>Natchez man killed in weekend accident</span></a></span></div>  </div>
  
      <div class="attachment">
  
  <div class="views-row views-row-2 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/two-tornadoes-hit-yazoo-county?most_read_source=week"><span>Two tornadoes hit Yazoo County</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-3 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/yazoo-citys-freds-store-close?most_read_source=week"><span>Yazoo City&#039;s Fred&#039;s store to close</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-4 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/opinion-editorials/state-takeover-could-be-good-yazoos-youth?most_read_source=week"><span>State takeover could be good for Yazoo&#039;s youth</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-5 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news-lifestyles/chamber-welcomes-cb-yazoo-business-community?most_read_source=week"><span>Chamber welcomes C&amp;B to Yazoo business community</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-6 views-row-even views-row-last">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-lifestyles/local-students-join-honor-society-holmes-cc?most_read_source=week"><span>Local students join honor society at Holmes CC</span></a></span></div>  </div>

</div>
    </div>
  
      <h2 class="element-invisible">Pages</h2><div class="item-list"><ul class="pager"><li class="pager-current first">1</li>
<li class="pager-item"><a title="Go to page 2" href="/obituaries/irene-street?page=0%2C0%2C1">2</a></li>
<li class="pager-item"><a title="Go to page 3" href="/obituaries/irene-street?page=0%2C0%2C2">3</a></li>
<li class="pager-ellipsis">…</li>
<li class="pager-next"><a title="Go to next page" href="/obituaries/irene-street?page=0%2C0%2C1">next ›</a></li>
<li class="pager-last last"><a title="Go to last page" href="/obituaries/irene-street?page=0%2C0%2C4">last »</a></li>
</ul></div>  
  
  
  
  
</div></div><div  id="quicktabs-tabpage-most_read_headline-1" class="quicktabs-tabpage quicktabs-hide"><div class="view view-most-read-headline view-id-most_read_headline view-display-id-block_2 view-dom-id-c4e386481b51ad82341826bc58fefb81">
        
  
  
      <div class="view-content">
      
  
  
  <div class="views-row views-row-1 views-row-odd views-row-first">
    <div class="views-field views-field-field-image"><div class="field-content"></div></div><div class="views-field views-field-title"><span class="field-content"><a href="/obituaries/helen-louise-reyer?most_read_source=month"><span>Helen Louise Reyer</span></a></span></div>  </div>
  
      <div class="attachment">
  
  <div class="views-row views-row-2 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/family-tradition-saxton-bringing-back-favorite-local-business-reopening-cb?most_read_source=month"><span>Family Tradition: Saxton bringing back a favorite local business by reopening C&amp;B Quick Shop</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-3 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/opinion-columnists/farewell-true-american-hero?most_read_source=month"><span>Farewell to a true American hero</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-4 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/hometown-hero-hooker-gives-back-his-community?most_read_source=month"><span>Hometown Hero: Hooker gives back to his community</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-5 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/obituaries/donald-donnie-scroggins?most_read_source=month"><span>Donald &quot;Donnie&quot; Scroggins</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-6 views-row-even views-row-last">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/newman-green-masters-art-balance?most_read_source=month"><span>Newman-Green masters the art of &quot;balance&quot;</span></a></span></div>  </div>

</div>
    </div>
  
      <h2 class="element-invisible">Pages</h2><div class="item-list"><ul class="pager"><li class="pager-current first">1</li>
<li class="pager-item"><a title="Go to page 2" href="/obituaries/irene-street?page=0%2C0%2C1">2</a></li>
<li class="pager-item"><a title="Go to page 3" href="/obituaries/irene-street?page=0%2C0%2C2">3</a></li>
<li class="pager-ellipsis">…</li>
<li class="pager-next"><a title="Go to next page" href="/obituaries/irene-street?page=0%2C0%2C1">next ›</a></li>
<li class="pager-last last"><a title="Go to last page" href="/obituaries/irene-street?page=0%2C0%2C20">last »</a></li>
</ul></div>  
  
  
  
  
</div></div><div  id="quicktabs-tabpage-most_read_headline-2" class="quicktabs-tabpage quicktabs-hide"><div class="view view-most-read-headline view-id-most_read_headline view-display-id-block view-dom-id-4863cb794662ac289cea2f96967514a9">
        
  
  
      <div class="view-content">
      
  
  
  <div class="views-row views-row-1 views-row-odd views-row-first">
    <div class="views-field views-field-field-image"><div class="field-content"><a href="/front-page-slideshow-news/still-unbeaten"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/0505coker.jpg?itok=w0_TJ2-D" width="100" height="67" alt="" /></span></a></div></div><div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/still-unbeaten?most_read_source=year"><span>Still Unbeaten</span></a></span></div>  </div>
  
      <div class="attachment">
  
  <div class="views-row views-row-2 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/humphries-crowned-yazoo-county-homecoming-queen?most_read_source=year"><span>Humphries crowned Yazoo County Homecoming Queen</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-3 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/debra-crook-elected-lions-club-president?most_read_source=year"><span>Debra Crook elected Lions Club president</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-4 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/news/blood-drive-benefit-mrs-dotsie-roberts?most_read_source=year"><span>Blood Drive to benefit Mrs. Dotsie Roberts</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-5 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/i-want-be-light-god-wants-me-be?most_read_source=year"><span>&quot;I want to be the light that God wants me to be.&quot;</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-6 views-row-even views-row-last">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/foster-care-needs-mississippi?most_read_source=year"><span>Foster care needs in Mississippi</span></a></span></div>  </div>

</div>
    </div>
  
      <h2 class="element-invisible">Pages</h2><div class="item-list"><ul class="pager"><li class="pager-current first">1</li>
<li class="pager-item"><a title="Go to page 2" href="/obituaries/irene-street?page=1">2</a></li>
<li class="pager-item"><a title="Go to page 3" href="/obituaries/irene-street?page=2">3</a></li>
<li class="pager-ellipsis">…</li>
<li class="pager-next"><a title="Go to next page" href="/obituaries/irene-street?page=1">next ›</a></li>
<li class="pager-last last"><a title="Go to last page" href="/obituaries/irene-street?page=163">last »</a></li>
</ul></div>  
  
  
  
  
</div></div><div  id="quicktabs-tabpage-most_read_headline-3" class="quicktabs-tabpage quicktabs-hide"><div class="view view-most-read-headline view-id-most_read_headline view-display-id-block_3 view-dom-id-53b32044381cca941c162bb2826b6f8f">
        
  
  
      <div class="view-content">
      
  
  
  <div class="views-row views-row-1 views-row-odd views-row-first">
    <div class="views-field views-field-field-image"><div class="field-content"><a href="/front-page-slideshow-news/riding-after-dream"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/1231leiannwaters.jpg?itok=wYfxc7wP" width="100" height="75" alt="" /></span></a></div></div><div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/riding-after-dream?most_read_source=all"><span>Riding After a Dream</span></a></span></div>  </div>
  
      <div class="attachment">
  
  <div class="views-row views-row-2 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/crimm-completes-term-president?most_read_source=all"><span>Crimm completes term as president</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-3 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/obituaries/bill-beeson?most_read_source=all"><span>Bill Beeson</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-4 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/obituaries/albert-woodley-cook-jr?most_read_source=all"><span>Albert Woodley Cook Jr.</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-5 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/obituaries/shirley-summerlin?most_read_source=all"><span>Shirley Summerlin</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-6 views-row-even views-row-last">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/moonlight-and-mistletoe?most_read_source=all"><span>Moonlight and Mistletoe</span></a></span></div>  </div>

</div>
    </div>
  
      <h2 class="element-invisible">Pages</h2><div class="item-list"><ul class="pager"><li class="pager-current first">1</li>
<li class="pager-item"><a title="Go to page 2" href="/obituaries/irene-street?page=0%2C0%2C0%2C1">2</a></li>
<li class="pager-item"><a title="Go to page 3" href="/obituaries/irene-street?page=0%2C0%2C0%2C2">3</a></li>
<li class="pager-ellipsis">…</li>
<li class="pager-next"><a title="Go to next page" href="/obituaries/irene-street?page=0%2C0%2C0%2C1">next ›</a></li>
<li class="pager-last last"><a title="Go to last page" href="/obituaries/irene-street?page=0%2C0%2C0%2C710">last »</a></li>
</ul></div>  
  
  
  
  
</div></div></div></div>  </div>

</div></div> <div id="block-dfp-6ec450dc64bec11f9139a33b3f21ce9e" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_bottom_right_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_bottom_right_widget_medium_rectangle&sz=600x500&c=96032">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_bottom_right_widget_medium_rectangle&sz=600x500&c=96032">
</a>
</div>  </div>

</div></div>   </div>
</div>
        <div class="grid_0"></div>
      </section>
          </div></div>  
     
   
    
<!-- All Hail the Footer -->
  <div class="footer-wrapper"><div class="footer-wrapper-inner container_12">
    <footer id="footer" class="grid_12 clearfix">
        <div class="region region-footer">
    <div id="block-block-3" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		 <p style="text-align: center;"><span style="font-size:11px;">Copyright 2015 • The Yazoo Herald • 1035 Grand Ave. • Yazoo City, MS 39194 • (662) 746-4911</span></p>
<p style="text-align: center;"><span style="font-size:11px;">Emmerich Newspapers proudly serve the following Mississippi communities:</span></p>
<p style="font-size: 13.008px; text-align: center;"><strong><span style="font-size: 11px;"><span style="line-height: 1.538em;">ACKERMAN • <a href="http://winonatimes.com/" target="_blank">CARROLLTON</a> • <a href="http://tallahatchienews.ms" target="_blank">CHARLESTON</a> • CLARKSDALE • <a href="http://columbianprogress.com" target="_blank">COLUMBIA</a> • EUPORA • <a href="http://sctonline.net" target="_blank">FOREST</a> • <a href="http://ddtonline.com" target="_blank">GREENVILLE</a> • <a href="http://gwcommonwealth.com" target="_blank">GREENWOOD</a> • <a href="http://HubCitySPOKES.com" target="_blank">HATTIESBURG</a></span><br /><span style="line-height: 1.538em;"><a href="http://northsidesun.com" target="_blank">JACKSON</a> • <a href="http://starherald.net" target="_blank">KOSCIUSKO</a> • <a href="http://enterprise-tocsin.com" target="_blank">INDIANOLA</a> • <a href="http://thechronicle.ms" target="_blank">LAUREL</a> • LOUISVILLE • <a href="http://simpsoncounty.ms" target="_blank">MAGEE</a> • <a href="http://simpsoncounty.ms" target="_blank">MENDENHALL</a> • <a href="http://enterprise-journal.com" target="_blank">McCOMB</a> • <a href="http://newtoncountyappeal.com" target="_blank">NEWTON</a> • <a href="http://HubCitySPOKES.com" target="_blank">PETAL</a> • <a href="http://clarkecountytrib.com" target="_blank">QUITMAN</a> • <a href="http://winonatimes.com/" target="_blank">WINONA</a> • <a href="http://yazooherald.net" target="_blank">YAZOO CITY</a></span></span></strong></p>
<p style="font-size: 13.008px; text-align: center;"><strong><span style="font-size: 11px;">As well as the following communities: DUMAS, Ark., <a href="http://madisonjournal.com" target="_blank">TALLULAH, La.</a>, and FRANKLINTON, La.</span></strong></p>
<p style="text-align: center;"><span style="font-size:11px;"><em>For more information on how to extend your advertising message to these communities, <a href="/emmerich-contact-form">click here.</a></em></span></p>
   </div>

</div></div> <div id="block-dfp-yaz-footer-leaderboard" class="block block-dfp"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_footer_leaderboard-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_footer_leaderboard&sz=600x500&c=47331">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_footer_leaderboard&sz=600x500&c=47331">
</a>
</div>  </div>

</div></div>   </div>
      
    </footer><!-- /footer -->
  </div></div>
 
</div><!-- page -->  <script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/addthis/addthis.js?pn9nqr"></script>
</body>

</html>