<!DOCTYPE html>
<html lang="en" dir="ltr" >

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="apple-touch-icon" href="//www.yazooherald.net/sites/default/files/yazoo-favicon_1.jpg" type="image/jpeg" />
<meta property="og:type" content="Article" /><meta property="og:title" content="Mary Elizabeth &quot;Dibbus&quot; McGowan"/><meta property="og:url" content="https://www.yazooherald.net/obituaries/mary-elizabeth-dibbus-mcgowan"/><meta property="og:image" content="//www.yazooherald.net/sites/default/files/TheYazooHeraldWebLogo2.png"/><meta property="fb:admins" content="dgustoughson"><meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="/obituaries/mary-elizabeth-dibbus-mcgowan" />
<link rel="shortlink" href="/node/4952" />
<link rel="shortcut icon" href="//www.yazooherald.net/sites/default/files/yazoo-favicon_2.jpg" type="image/jpeg" />
  <title>Mary Elizabeth &quot;Dibbus&quot; McGowan | The Yazoo Herald</title>  
  <style type="text/css" media="all">
@import url("//www.yazooherald.net/modules/system/system.base.css?pu0l2p");
@import url("//www.yazooherald.net/modules/system/system.menus.css?pu0l2p");
@import url("//www.yazooherald.net/modules/system/system.messages.css?pu0l2p");
@import url("//www.yazooherald.net/modules/system/system.theme.css?pu0l2p");
</style>
<style type="text/css" media="all">
@import url("//www.yazooherald.net/misc/ui/jquery.ui.core.css?pu0l2p");
@import url("//www.yazooherald.net/misc/ui/jquery.ui.theme.css?pu0l2p");
@import url("//www.yazooherald.net/misc/ui/jquery.ui.button.css?pu0l2p");
@import url("//www.yazooherald.net/misc/ui/jquery.ui.resizable.css?pu0l2p");
@import url("//www.yazooherald.net/misc/ui/jquery.ui.dialog.css?pu0l2p");
</style>
<style type="text/css" media="all">
@import url("//www.yazooherald.net/modules/aggregator/aggregator.css?pu0l2p");
@import url("//www.yazooherald.net/sites/all/modules/calendar/css/calendar_multiday.css?pu0l2p");
@import url("//www.yazooherald.net/sites/all/modules/date/date_api/date.css?pu0l2p");
@import url("//www.yazooherald.net/sites/all/modules/date/date_popup/themes/datepicker.1.7.css?pu0l2p");
@import url("//www.yazooherald.net/modules/field/theme/field.css?pu0l2p");
@import url("//www.yazooherald.net/modules/node/node.css?pu0l2p");
@import url("//www.yazooherald.net/modules/search/search.css?pu0l2p");
@import url("//www.yazooherald.net/sites/all/modules/simpleads/simpleads.css?pu0l2p");
@import url("//www.yazooherald.net/sites/all/modules/ubercart/uc_order/uc_order.css?pu0l2p");
@import url("//www.yazooherald.net/sites/all/modules/ubercart/uc_product/uc_product.css?pu0l2p");
@import url("//www.yazooherald.net/sites/all/modules/ubercart/uc_store/uc_store.css?pu0l2p");
@import url("//www.yazooherald.net/modules/user/user.css?pu0l2p");
@import url("//www.yazooherald.net/sites/all/modules/views/css/views.css?pu0l2p");
</style>
<style type="text/css" media="all">
@import url("//www.yazooherald.net/sites/all/modules/ed_classified/theme/classified.css?pu0l2p");
@import url("//www.yazooherald.net/sites/all/modules/ctools/css/ctools.css?pu0l2p");
@import url("//www.yazooherald.net/sites/all/modules/event_calendar/event_popup/css/event_popup.css?pu0l2p");
@import url("//www.yazooherald.net/sites/all/modules/ctools/css/modal.css?pu0l2p");
@import url("//www.yazooherald.net/sites/all/modules/responsive_menus/styles/responsive_menus_simple/css/responsive_menus_simple.css?pu0l2p");
</style>
<link type="text/css" rel="stylesheet" href="/sites/all/modules/custom/emmerich_notifications/css/style.css" media="all" />
<style type="text/css" media="all">
@import url("//www.yazooherald.net/sites/all/modules/quicktabs/css/quicktabs.css?pu0l2p");
</style>
<style type="text/css" media="all">
@import url("//www.yazooherald.net/sites/all/themes/bones/css/normalize.css?pu0l2p");
@import url("//www.yazooherald.net/sites/all/themes/bones/css/formalize.css?pu0l2p");
@import url("//www.yazooherald.net/sites/all/themes/bones/css/grid_12.css?pu0l2p");
@import url("//www.yazooherald.net/sites/all/themes/bones/css/layout.css?pu0l2p");
</style>
<style type="text/css" media="all">
@import url("//www.yazooherald.net/sites/all/themes/current/css/style4.css?pu0l2p");
@import url("//www.yazooherald.net/sites/all/themes/current/css/responsive.css?pu0l2p");
@import url("//www.yazooherald.net/sites/all/themes/current/css/custom.css?pu0l2p");
</style>
  <script type="text/javascript" src="//www.yazooherald.net/misc/jquery.js?v=1.4.4"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/jquery.once.js?v=1.2"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.slots = googletag.slots || {};
//--><!]]>
</script>
<script type="text/javascript" src="//www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/drupal.js?pu0l2p"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.core.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.widget.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.button.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.mouse.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.draggable.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.position.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.resizable.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ui/jquery.ui.dialog.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/views/js/jquery.ui.dialog.patch.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/jquery.cookie.js?v=1.0"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/jquery.form.js?v=2.52"></script>
<script type="text/javascript" src="//www.yazooherald.net/misc/ajax.js?v=7.64"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/simpleads/simpleads.js?pu0l2p"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/simpleads/modules/simpleads_campaigns/simpleads_campaigns.js?pu0l2p"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
googletag.cmd.push(function() {
  googletag.pubads().enableAsyncRendering();
  googletag.pubads().enableSingleRequest();
  googletag.pubads().collapseEmptyDivs();
});

googletag.enableServices();
//--><!]]>
</script>
<script type="text/javascript" src="//www.yazooherald.net/misc/progress.js?pu0l2p"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/event_calendar/event_popup/js/event_popup.js?pu0l2p"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/event_calendar/event_popup/js/event_popup_validate.js?pu0l2p"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery(document).ready(function($) { 
    $.expr[':'].regex = function(elem, index, match) {
            var matchParams = match[3].split(','),
            validLabels = /^(data|css):/,
            attr = {
                method: matchParams[0].match(validLabels) ? 
                matchParams[0].split(':')[0] : 'attr',
                property: matchParams.shift().replace(validLabels,'')
            },
            regexFlags = 'ig',
            regex = new RegExp(matchParams.join('').replace(/^\s+|\s+$/g,''), regexFlags);
            return regex.test(jQuery(elem)[attr.method](attr.property));
        }
    });
//--><!]]>
</script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/ctools/js/modal.js?pu0l2p"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/views/js/base.js?pu0l2p"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var switchTo5x = true;var useFastShare = true;
//--><!]]>
</script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/views/js/ajax_view.js?pu0l2p"></script>
<script type="text/javascript" src="https://ws.sharethis.com/button/buttons.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (typeof stLight !== 'undefined') { stLight.options({"publisher":"fc937732-3d58-4754-8720-1d210502838c","version":"5x","doNotCopy":false,"hashAddressBar":true,"doNotHash":false,"onhover":false,"newOrZero":"zero","lang":"en"}); }
//--><!]]>
</script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/responsive_menus/styles/responsive_menus_simple/js/responsive_menus_simple.js?pu0l2p"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/google_analytics/googleanalytics.js?pu0l2p"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","//www.google-analytics.com/analytics.js","ga");ga("create", "UA-75225316-16", {"cookieDomain":"auto"});ga("set", "anonymizeIp", true);ga("send", "pageview");
//--><!]]>
</script>
<script type="text/javascript" src="/sites/all/modules/custom/emmerich_notifications/js/script.js"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/fb_likebox/fb_likebox.js?pu0l2p"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/quicktabs/js/quicktabs.js?pu0l2p"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/bones/js/jquery.formalize.min.js?pu0l2p"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/bones/js/superfish.js?pu0l2p"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/current/js/scripts.js?pu0l2p"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/bones/js/jquery.easing.1.3.js?pu0l2p"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/bones/js/jquery.equal-height-columns.js?pu0l2p"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/current/js/jquery.mobilemenu.min.js?pu0l2p"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/current/js/jquery.color.js?pu0l2p"></script>
<script type="text/javascript" src="//www.yazooherald.net/sites/all/themes/current/js/jquery-glowing.js?pu0l2p"></script>
<script type="text/javascript">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</script>
  <meta name="viewport" content="width=device-width, initial-scale=1">  
  <!--[if lt IE 9]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
  <link href='//fonts.googleapis.com/css?family=Paytone+One' rel='stylesheet' type='text/css'>
  <script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-8039211595423832",
    enable_page_level_ads: true
  });
</script>

</head>

<body class="html not-front not-logged-in one-sidebar sidebar-second page-node page-node- page-node-4952 node-type-article sidebars-split obituaries mary-elizabeth-dibbus-mcgowan">
  <div id="skip-link">
    <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    <div id="page">

  <div class="user-menu-wrapper"><div class="user-menu-wrapper-inner container_12">  
    <nav id="user-menu" class="grid_12 clearfix">
        <div class="region region-user-menu">
    <div id="block-system-user-menu" class="block block-system block-menu"><div class="block-inner">

	      <h3 class="title"><span>User menu</span></h3>
     
  <div class="content">
		<ul class="menu"><li class="first last leaf"><a href="/user/login" title=""><span>Login</span></a></li>
</ul>  </div>

</div></div>   </div>
        <div class="region region-search-box">
    <div id="block-search-form" class="block block-search"><div class="block-inner">

	     
  <div class="content">
		<form onsubmit="if(this.search_block_form.value==&#039;Search&#039;){ alert(&#039;Please enter a search&#039;); return false; }" action="/obituaries/mary-elizabeth-dibbus-mcgowan" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." onblur="if (this.value == &#039;&#039;) {this.value = &#039;Search&#039;;}" onfocus="if (this.value == &#039;Search&#039;) {this.value = &#039;&#039;;}" type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-OYWR9fhEk_fpn67bbk9smIUDqWIKV9xWjYXtLmBkdrU" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form>  </div>

</div></div>   </div>
      <div id="social">
        <ul class="social-links">
          <li><a class="rss" href="/rss.xml"></a></li>
          <li><a class="twitter" href="http://www.twitter.com"></a></li>
          <li><a class="facebook" href="http://www.facebook.com"></a></li>
        </ul>
      </div>         
    </nav>
  </div></div>

  <div class="header-wrapper"><div class="header-wrapper-inner container_12">
    <header class="grid_12 clearfix">
            <div class="logo-slogan">  
        
                  <div class="site-logo">
            <a href="/"><img src="//www.yazooherald.net/sites/default/files/TheYazooHeraldWebLogo2.png" alt="" /></a>
          </div>
        	      
        
        <hgroup>
        
                    
                     
        
        </hgroup> 
  
      </div>

           
    </header>  
    
  </div></div>

      
    <div class="main-menu-wrapper"><div class="main-menu-wrapper-inner container_12">  
      <nav id="main-menu" class="grid_12 clearfix">
          <div class="region region-main-menu">
    <div id="block-system-main-menu" class="block block-system block-menu"><div class="block-inner">

	      <h3 class="title"><span>Main menu</span></h3>
     
  <div class="content">
		<ul class="menu"><li class="first expanded"><a href="/" title="Home"><span>Home</span></a><ul class="menu"><li class="first leaf"><a href="/about-us"><span>About Us</span></a></li>
<li class="leaf"><a href="/our-staff" title="Our Staff"><span>Our Staff</span></a></li>
<li class="leaf"><a href="/faqs" title="FAQ&#039;s"><span>FAQ&#039;s</span></a></li>
<li class="last leaf"><a href="/contact-us" title="Contact Us"><span>Contact Us</span></a></li>
</ul></li>
<li class="leaf"><a href="http://yazooherald.net/eedition-front" title=""><span>E-Edition</span></a></li>
<li class="leaf"><a href="/obituaries" title="Obituaries"><span>Obituaries</span></a></li>
<li class="leaf"><a href="/taxonomy/term/4" title="Sports"><span>Sports</span></a></li>
<li class="expanded"><a href="/opinion" title="Opinion"><span>Opinion</span></a><ul class="menu"><li class="first leaf"><a href="/columnists" title="Columnists"><span>Columnists</span></a></li>
<li class="leaf"><a href="/editorials" title="Editorials"><span>Editorials</span></a></li>
<li class="last leaf"><a href="/letters-editor" title="Letters to the Editor"><span>Letters to the Editor</span></a></li>
</ul></li>
<li class="expanded"><a href="/classified" title=""><span>Advertising</span></a><ul class="menu"><li class="first leaf"><a href="/classified/75" title=""><span>Legal Notices</span></a></li>
<li class="leaf"><a href="/newspaper-rates"><span>Newspaper Rates</span></a></li>
<li class="leaf"><a href="http://yazooherald.net/place-classified-ad-1" title=""><span>Place a Classified Ad</span></a></li>
<li class="last leaf"><a href="/website-rates"><span>Website Rates</span></a></li>
</ul></li>
<li class="expanded"><a href="/subscribe"><span>Subscribe</span></a><ul class="menu"><li class="first last leaf"><a href="/yazoo-herald"><span>The Yazoo Herald</span></a></li>
</ul></li>
<li class="last collapsed"><a href="/news"><span>News</span></a></li>
</ul>  </div>

</div></div>   </div>
      </nav>
    </div></div> 
      
  
  <div class="main-menu-second-level-wrapper clearfix"><div class="main-menu-second-level-wrapper-inner container_12">  
    <nav id="main-menu-second-level" class="grid_12">
            
    </nav>
  </div></div> 
  
<!-- Main Content -->  
  <div class="main-content-wrapper"><div class="main-content-wrapper-inner container_12">
    <section id="main-content" class="clearfix"> 	   

          
    
      <div class="main">
        <div class="main-inner  grid_8">
                    
	      
        
                                          
            <div class="region region-content-top">
    <div id="block-dfp-yaz-top-leaderboard" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_top_leaderboard-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_top_leaderboard&sz=600x500&c=99932">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_top_leaderboard&sz=600x500&c=99932">
</a>
</div>  </div>

</div></div>   </div>
                                          <div class="region region-content">
    <div id="block-system-main" class="block block-system"><div class="block-inner">

	     
  <div class="content">
		<article id="node-4952" class="node node-article node-promoted last clearfix">



  


  


  <div class="node-content-wrapper">



    


      


      
       <h1 class="title">Mary Elizabeth &quot;Dibbus&quot; McGowan</h1>

      


    


    


    
        <ul class="links inline"><li class="statistics_counter first last"><span>404 reads</span></li>
</ul>
    


    
      <div class="submitted">

            <span class="date">Tue, 07/02/2019 - 10:39am</span>

      </div>

    


    <div class="content">

    <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even"> <p>Mary Elizabeth "Dibbus" Luckett McGowan, age 95, of Yazoo City, passed away Saturday evening June 29, 2019.</p>
<p>She was born September 3, 1923, in Yazoo City. A graduate of Canton High School, Dibbus served as the editor of the school’s newspaper. She exercised her love of and talent for writing throughout her life by composing gracious letters and notes, displaying her beautiful penmanship.</p>
<p>Dibbus was married for 67 years to Daniel Patrick “Pat” McGowan Jr., who preceded her in death in 2013. Together, they had five children, 10 grandchildren and nine great-grandchildren. Dibbus enjoyed holidays with her family, traveling including many international adventures, and sweets—anything sweet. She was a devoted member of St. Mary’s Parish in Yazoo City.</p>
<p>She was preceded in death by her parents Erasmus Oliver and Catherine Cecelia (Sulm) Luckett; husband Daniel Patrick “Pat” McGowan, Jr.; daughter, Dr. Elizabeth Luckett McGowan Montgomery; brother William Oliver Luckett; and sisters, Jean Marie Luckett, Katherine Cobb Luckett Switzer, and Dorothy Luckett Dowdle.</p>
<p>She is survived by four of her children: Daniel Patrick McGowan, III of Clinton; Marilyn McGowan Meigs (Frank) of Tallahassee, Fla.; Michael Oliver McGowan (Katherine) of Madison; Catherine McGowan Stumpff of Greensboro, N.C.; and her son-in-law Dr. Charles Montgomery of Tupelo. Other survivors include sisters, Ann Margaret Ray of Crystal Springs, Marian Louise Lion of Long Beach, and Mildred Josephine Carns of Champaign, Ill.; sister-in-law, Bobbie Nell Herrington McGowan of Columbia; 10 grandchildren; and nine great-grandchildren.</p>
<p>Visitation will be held at St. Mary’s Catholic Church from 9-10 a.m. on Friday, July 5th. A Mass of Christian Burial will follow at 10 a.m. at St. Mary’s Catholic Church with interment in the Glenwood Cemetery to follow. Stricklin-King Funeral Home has been entrusted with the arrangements.</p>
<p>Memorials are to be sent to St. Mary's Church (P. O. Box 27, Yazoo City, MS 39194-0027) or your charity of choice.</p><div class="ad">
        <div class="left"><div id="block-dfp-9b800b9bf1a6c91698aa78c8a7cffe14" class="block block-dfp adServeMargin"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_top_left_in_story_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_top_left_in-story_medium_rectangle&sz=600x500&c=94854">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_top_left_in-story_medium_rectangle&sz=600x500&c=94854">
</a>
</div>  </div>

</div></div> </div>
        </div>
 </div></div></div><div class="item-list"><ul class="pager-for-content-type flippy"><li class="pager-previous prev first"><a href="/obituaries/joan-fisher-moore" class="prev"><span>‹ Previous</span></a></li>
<li class="pager-next next last"><a href="/obituaries/government-owns-too-much-land" class="next"><span>Next ›</span></a></li>
</ul></div>
    </div>







    
      <nav class="taxonomy"><div class="taxonomy-inner clearfix">

        
      </div></nav>

    


  
      <nav class="taxonomy"><div class="taxonomy-inner clearfix">

        
      </div></nav>

    


 






  </div>





</article>




  </div>

</div></div> <div id="block-sharethis-sharethis-block" class="block block-sharethis"><div class="block-inner">

	     
  <div class="content">
		<div class="sharethis-wrapper"><span st_url="https://www.yazooherald.net/obituaries/mary-elizabeth-dibbus-mcgowan" st_title="Mary Elizabeth &quot;Dibbus&quot; McGowan" class="st_facebook_button" displayText="facebook"></span>
<span st_url="https://www.yazooherald.net/obituaries/mary-elizabeth-dibbus-mcgowan" st_title="Mary Elizabeth &amp;quot;Dibbus&amp;quot; McGowan" class="st_twitter_button" displayText="twitter" st_via="" st_username=""></span>
<span st_url="https://www.yazooherald.net/obituaries/mary-elizabeth-dibbus-mcgowan" st_title="Mary Elizabeth &quot;Dibbus&quot; McGowan" class="st_pinterest_button" displayText="pinterest" st_via="" st_username=""></span>
<span st_url="https://www.yazooherald.net/obituaries/mary-elizabeth-dibbus-mcgowan" st_title="Mary Elizabeth &quot;Dibbus&quot; McGowan" class="st_tumblr_button" displayText="tumblr" st_via="" st_username=""></span>
<span st_url="https://www.yazooherald.net/obituaries/mary-elizabeth-dibbus-mcgowan" st_title="Mary Elizabeth &quot;Dibbus&quot; McGowan" class="st_email_button" displayText="email" st_via="" st_username=""></span>
<span st_url="https://www.yazooherald.net/obituaries/mary-elizabeth-dibbus-mcgowan" st_title="Mary Elizabeth &quot;Dibbus&quot; McGowan" class="st_fblike_button" displayText="fblike" st_via="" st_username=""></span>
</div>  </div>

</div></div> <div id="block-facebook-comments-box-facebook-comments-box" class="block block-facebook-comments-box"><div class="block-inner">

	     
  <div class="content">
		<div class="facebook-comments-box"><div id="fb-root"></div><script src="http://connect.facebook.net/en_US/all.js#xfbml=1"></script><fb:comments href="https://www.yazooherald.net/obituaries/mary-elizabeth-dibbus-mcgowan"  num_posts="10"  width="580"  colorscheme="light" ></fb:comments></div>  </div>

</div></div> <div id="block-dfp-yaz-medium-leaderboard" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_medium_leaderboard-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_medium_leaderboard&sz=600x500&c=74523">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_medium_leaderboard&sz=600x500&c=74523">
</a>
</div>  </div>

</div></div>   </div>
  
                  
                            </div> 
                <aside class="sidebar second-sidebar grid_4">
              <div class="region region-second-ad">
    <div id="block-block-39" class="block block-block sign-up-for-emmerich-notifications"><div class="block-inner">

	      <h3 class="title"><span>Sign Up for Notifications of Local Breaking News</span></h3>
     
  <div class="content">
		<p><a class="ctools-use-modal" href="/emmerich/subscribe/email/js">Start E-mail Notifications</a></p>
<p><a class="ctools-use-modal" href="/emmerich/unsubscribe/email-popup/js">Stop E-mail Notifications</a></p>
<p><a class="ctools-use-modal" href="/emmerich/subscribe/mobile/js">Start Mobile Notifications</a></p>
<p><a class="ctools-use-modal" href="/emmerich/unsubscribe/mobile/js">Stop Mobile Notifications</a></p>  </div>

</div></div> <div id="block-simpleads-ad-groups-148" class="block block-simpleads"><div class="block-inner">

	     
  <div class="content">
		<div class="header">
  <div class="ad-link"></div>
</div>
<div class="adslist">
  <script type="text/javascript">
    _simpelads_load('.simpleads-148', 148, 1);
  </script>
    <div class="simpleads-148"></div>

    
</div>
  </div>

</div></div> <div id="block-dfp-1274a596e817b07731a6dd25e59304b9" class="block block-dfp"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_middle_1_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_middle_1_skyscraper_medium_rectangle&sz=600x500&c=82993">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_middle_1_skyscraper_medium_rectangle&sz=600x500&c=82993">
</a>
</div>  </div>

</div></div> <div id="block-dfp-811705d3a59b91b8c7f39a799e6db3d2" class="block block-dfp"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_middle_2_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_middle_2_skyscraper_medium_rectangle&sz=600x500&c=28664">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_middle_2_skyscraper_medium_rectangle&sz=600x500&c=28664">
</a>
</div>  </div>

</div></div> <div id="block-dfp-7a6379ada523077fb90dad055db25fcd" class="block block-dfp"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_middle_3_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_middle_3_skyscraper_medium_rectangle&sz=600x500&c=86011">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_middle_3_skyscraper_medium_rectangle&sz=600x500&c=86011">
</a>
</div>  </div>

</div></div> <div id="block-dfp-d553375fd438aac474d494703dd8cbcf" class="block block-dfp"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_middle_4_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_middle_4_skyscraper_medium_rectangle&sz=600x500&c=98028">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_middle_4_skyscraper_medium_rectangle&sz=600x500&c=98028">
</a>
</div>  </div>

</div></div> <div id="block-dfp-cd27e71fcafc6df168fe3e8d3f26f55e" class="block block-dfp"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_middle_5_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_middle_5_skyscraper_medium_rectangle&sz=600x500&c=87667">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_middle_5_skyscraper_medium_rectangle&sz=600x500&c=87667">
</a>
</div>  </div>

</div></div> <div id="block-block-38" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		 <p style="text-align: center;"><a href="/most-read"><img alt="" class="media-image" height="576" style="width: 300px; height: 400px;" width="432" src="//www.yazooherald.net/sites/default/files/styles/large/public/Most-Read-Stories_3.jpg?itok=doq9Pp2i" /></a></p>
   </div>

</div></div> <div id="block-dfp-9359c0c7eebbe7338728ed2e38077cf2" class="block block-dfp"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_middle_6_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_middle_6_skyscraper_medium_rectangle&sz=600x500&c=49688">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_middle_6_skyscraper_medium_rectangle&sz=600x500&c=49688">
</a>
</div>  </div>

</div></div> <div id="block-dfp-4ff26d5a44d4cfa416af713791252845" class="block block-dfp"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_bottom_skyscraper_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_bottom_skyscraper_medium_rectangle&sz=600x500&c=94561">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_bottom_skyscraper_medium_rectangle&sz=600x500&c=94561">
</a>
</div>  </div>

</div></div>   </div>
              <div class="region region-sidebar-second">
    <div id="block-fb-likebox-0" class="block block-fb-likebox adServeMargin"><div class="block-inner">

	     
  <div class="content">
		<div class="fb-page" data-href="https://www.facebook.com/yazooherald" data-width="300" data-height="500" data-tabs="timeline" data-hide-cover="0" data-show-facepile="1" data-hide-cta="0" data-small-header="0" data-adapt-container-width="1"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/yazooherald"><a href="https://www.facebook.com/yazooherald"><span>Like us on Facebook</span></a></blockquote></div></div>  </div>

</div></div>   </div>
                
        </aside>
             
      </div>            
  
    </section>
  </div></div>
  
    
    <div class="preface-wrapper"><div class="preface-wrapper-inner container_12">  
      <section id="preface" class="clearfix">
        <div class="grid_4">  <div class="region region-preface-1">
    <div id="block-dfp-87fbf52277b8f3e22005a04574690781" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_top_left_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_top_left_widget_medium_rectangle&sz=600x500&c=46783">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_top_left_widget_medium_rectangle&sz=600x500&c=46783">
</a>
</div>  </div>

</div></div> <div id="block-views-weddings-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>News</span></h3>
     
  <div class="content">
		<div class="view view-weddings view-id-weddings view-display-id-block view-dom-id-a1c4747bd8a07ad5b124419f74549044">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/news/man-charged-shooting-woman-after-argument"><span>Man charged with shooting at woman after argument</span></a></span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"> <p>A shooting in rural Yazoo County last weekend left one man behind bars and, fortunately, no... <a href="/news/man-charged-shooting-woman-after-argument" class="views-more-link"><span>READ MORE</span></a></div>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-weddings view-id-weddings view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/news/former-chancery-clerk-complete-tax-assessor-term"><span>Former chancery clerk to complete tax assessor term</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/news/city-makes-six-board-appointments"><span>City makes six board appointments</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/news/ada-upgrades-coming-some-county-voting-precincts"><span>ADA upgrades coming for some county voting precincts</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-news/tax-assessor-retires-after-32-years"><span>Tax Assessor retires after 32 years </span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-news/stevens-retires-postal-service"><span>Stevens retires from Postal Service</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-dfp-3c05c49e0431377e33c85c006c823ec8" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_middle_left_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_middle_left_widget_medium_rectangle&sz=600x500&c=57707">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_middle_left_widget_medium_rectangle&sz=600x500&c=57707">
</a>
</div>  </div>

</div></div> <div id="block-views-sports-recent-stories-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Sports</span></h3>
     
  <div class="content">
		<div class="view view-sports-recent-stories view-id-sports_recent_stories view-display-id-block view-dom-id-2f21bc7efdf0708482939fe6b5a219a3">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="/front-page-slideshow-sports/2019-ba-elementary-basketball-camp"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/0622basketballcamp.jpg?itok=ZqOkXu1l" width="100" height="63" alt="" /></span></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-sports/2019-ba-elementary-basketball-camp"><span>2019 BA Elementary Basketball Camp</span></a></span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"> <p>Benton Academy recently hosted its 2019 Elementary Basketball Camp.</p></div>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-sports-recent-stories view-id-sports_recent_stories view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-sports/bringing-heat"><span>Bringing the Heat</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-sports/yazoo-sluggers-win-central-ms-title"><span>Yazoo Sluggers win Central MS title</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-sports/smiling-plate"><span>Smiling at the Plate</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-sports/former-nfl-player-brings-program-yazoo"><span>Former NFL player brings program to Yazoo</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/sports/coghlan-competes-all-star-game"><span>Coghlan competes in All Star Game</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-dfp-bbb6111ef381ac4528ed9ec51a11513d" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_bottom_left_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_bottom_left_widget_medium_rectangle&sz=600x500&c=65226">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_bottom_left_widget_medium_rectangle&sz=600x500&c=65226">
</a>
</div>  </div>

</div></div> <div id="block-block-34" class="block block-block adServeMargin"><div class="block-inner">

	     
  <div class="content">
		<!--<script src='https://adsmopress.com/ads-state.php?u=235&s=4&d=MS' type='text/javascript'></script>-->  </div>

</div></div>   </div>
</div>
        <div class="grid_4">  <div class="region region-preface-2">
    <div id="block-dfp-e151e0c8b83cc13e94ea635eca46f2a4" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_top_middle_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_top_middle_widget_medium_rectangle&sz=600x500&c=24982">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_top_middle_widget_medium_rectangle&sz=600x500&c=24982">
</a>
</div>  </div>

</div></div> <div id="block-views-business-top-stories-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Opinion:</span></h3>
     
  <div class="content">
		<div class="view view-business-top-stories view-id-business_top_stories view-display-id-block view-dom-id-38201601e1c5717d3f435643424e1b1e">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-editorials/bring-back-objective-graduation-requirements"><span>Bring back objective graduation requirements</span></a></span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"> <p>Lt. Gov. Tate Reeves maintains Mississippi’s graduation rate has risen to the national average... <a href="/opinion-editorials/bring-back-objective-graduation-requirements" class="views-more-link"><span>READ MORE</span></a></div>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-business-top-stories view-id-business_top_stories view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-columnists/why-there-no-competition-bonds"><span>Why is there no competition for bonds?</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-columnists/better-way-deal-drugs"><span>A better way to deal with drugs</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-columnists/quality-customer-service-matters"><span>Quality customer service matters</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-columnists/dancing-champions-hot-springs"><span>The dancing champions of Hot Springs</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-columnists/mr-mott-was-great-mentor"><span>Mr. Mott was a great mentor</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-dfp-3060d53de97465e1e01fc2e67a9fa96b" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_middle_middle_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_middle_middle_widget_medium_rectangle&sz=600x500&c=18759">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_middle_middle_widget_medium_rectangle&sz=600x500&c=18759">
</a>
</div>  </div>

</div></div> <div id="block-views-social-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Lifestyles</span></h3>
     
  <div class="content">
		<div class="view view-social view-id-social view-display-id-block view-dom-id-77c7c500255a76960a4615458d062d07">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="/lifestyles/miss-riley-wed-strickland-june-29-flora"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/0619strickland.jpg?itok=IkiuLWWt" width="100" height="70" alt="" /></span></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/lifestyles/miss-riley-wed-strickland-june-29-flora"><span>Miss Riley to wed Strickland on June 29 in Flora</span></a></span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"> <p>Mr. and Mrs. Sean Riley of Madison announce the engagement of their daughter, Victoria Ashlyn,... <a href="/lifestyles/miss-riley-wed-strickland-june-29-flora" class="views-more-link"><span>READ MORE</span></a></div>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-social view-id-social view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/lifestyles/yazoo-city-fire-academy-graduates"><span>Yazoo City Fire Academy graduates </span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/lifestyles/yazoo-dar-chapter-installs-officers"><span>Yazoo DAR chapter installs officers</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/lifestyles/fulton-visits-her-hometown-rotary-club"><span>Fulton visits her hometown Rotary Club</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-lifestyles/hometown-hero-kaleb-eulls-volunteers-yazoo-county-high-school"><span>Hometown hero Kaleb Eulls volunteers at Yazoo County High School</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-lifestyles/tag-youre-it"><span>Tag, You&#039;re It!</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-dfp-6b8651675a962a883c58715d14e02ea5" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_bottom_middle_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_bottom_middle_widget_medium_rectangle&sz=600x500&c=91014">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_bottom_middle_widget_medium_rectangle&sz=600x500&c=91014">
</a>
</div>  </div>

</div></div>   </div>
</div>
        <div class="grid_4">  <div class="region region-preface-3">
    <div id="block-dfp-20020ae2463e841eb50a99d9f52eb769" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_top_right_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_top_right_widget_medium_rectangle&sz=600x500&c=59400">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_top_right_widget_medium_rectangle&sz=600x500&c=59400">
</a>
</div>  </div>

</div></div> <div id="block-views-obituaries-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Obituaries</span></h3>
     
  <div class="content">
		<div class="view view-obituaries view-id-obituaries view-display-id-block view-dom-id-dcd6445ec3992e68c8a8bb6288cfdbd8">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="/obituaries/government-owns-too-much-land"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/walter patterson_5.jpg?itok=k9VDFm0u" width="100" height="62" alt="" /></span></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/government-owns-too-much-land"><span>The government owns too much land</span></a></span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"> <p>Tomorrow we will celebrate Independence Day, the day the colonies declared themselves free of... <a href="/obituaries/government-owns-too-much-land" class="views-more-link"><span>READ MORE</span></a></div>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-obituaries view-id-obituaries view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/mary-elizabeth-dibbus-mcgowan" class="active"><span>Mary Elizabeth &quot;Dibbus&quot; McGowan</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/joan-fisher-moore"><span>Joan Fisher Moore</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/howard-saxton"><span>Howard Saxton</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/wayne-vancleave-jr"><span>Wayne Vancleave Jr.</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/kenny-manor"><span>Kenny Manor</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-dfp-bf6f5f5865d744a4c5cff0637a56d6d0" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_middle_right_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_middle_right_widget_medium_rectangle&sz=600x500&c=13930">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_middle_right_widget_medium_rectangle&sz=600x500&c=13930">
</a>
</div>  </div>

</div></div> <div id="block-quicktabs-most-read-headline" class="block block-quicktabs"><div class="block-inner">

	      <h3 class="title"><span>Most Read - Headline</span></h3>
     
  <div class="content">
		<div  id="quicktabs-most_read_headline" class="quicktabs-wrapper quicktabs-style-nostyle"><div class="item-list"><ul class="quicktabs-tabs quicktabs-style-nostyle"><li class="active first"><a href="/obituaries/mary-elizabeth-dibbus-mcgowan?qt-most_read_headline=0#qt-most_read_headline" id="quicktabs-tab-most_read_headline-0" class="active"><span>Week</span></a></li>
<li><a href="/obituaries/mary-elizabeth-dibbus-mcgowan?qt-most_read_headline=1#qt-most_read_headline" id="quicktabs-tab-most_read_headline-1" class="active"><span>Month</span></a></li>
<li><a href="/obituaries/mary-elizabeth-dibbus-mcgowan?qt-most_read_headline=2#qt-most_read_headline" id="quicktabs-tab-most_read_headline-2" class="active"><span>Year</span></a></li>
<li class="last"><a href="/obituaries/mary-elizabeth-dibbus-mcgowan?qt-most_read_headline=3#qt-most_read_headline" id="quicktabs-tab-most_read_headline-3" class="active"><span>All Time</span></a></li>
</ul></div><div id="quicktabs-container-most_read_headline" class="quicktabs_main quicktabs-style-nostyle"><div  id="quicktabs-tabpage-most_read_headline-0" class="quicktabs-tabpage "><div class="view view-most-read-headline view-id-most_read_headline view-display-id-block_1 view-dom-id-e3bc54c902f0c01720854f04659bf61e">
        
  
  
      <div class="view-content">
      
  
  
  <div class="views-row views-row-1 views-row-odd views-row-first">
    <div class="views-field views-field-field-image"><div class="field-content"><a href="/front-page-slideshow-news/stevens-retires-postal-service"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/0626stevens.jpg?itok=07nhyLTO" width="100" height="64" alt="" /></span></a></div></div><div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/stevens-retires-postal-service?most_read_source=week"><span>Stevens retires from Postal Service</span></a></span></div>  </div>
  
      <div class="attachment">
  
  <div class="views-row views-row-2 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/tax-assessor-retires-after-32-years?most_read_source=week"><span>Tax Assessor retires after 32 years </span></a></span></div>  </div>
  
  
  <div class="views-row views-row-3 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/news/ada-upgrades-coming-some-county-voting-precincts?most_read_source=week"><span>ADA upgrades coming for some county voting precincts</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-4 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/park-shooting-suspect-captured?most_read_source=week"><span>Park shooting suspect captured</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-5 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/obituaries/eric-girard?most_read_source=week"><span>Eric Girard</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-6 views-row-even views-row-last">
    <div class="views-field views-field-title"><span class="field-content"><a href="/obituaries/barbara-nell-ledlow-jones?most_read_source=week"><span>Barbara Nell Ledlow Jones</span></a></span></div>  </div>

</div>
    </div>
  
      <h2 class="element-invisible">Pages</h2><div class="item-list"><ul class="pager"><li class="pager-current first">1</li>
<li class="pager-item"><a title="Go to page 2" href="/obituaries/mary-elizabeth-dibbus-mcgowan?page=0%2C0%2C1">2</a></li>
<li class="pager-item"><a title="Go to page 3" href="/obituaries/mary-elizabeth-dibbus-mcgowan?page=0%2C0%2C2">3</a></li>
<li class="pager-next"><a title="Go to next page" href="/obituaries/mary-elizabeth-dibbus-mcgowan?page=0%2C0%2C1">next ›</a></li>
<li class="pager-last last"><a title="Go to last page" href="/obituaries/mary-elizabeth-dibbus-mcgowan?page=0%2C0%2C3">last »</a></li>
</ul></div>  
  
  
  
  
</div></div><div  id="quicktabs-tabpage-most_read_headline-1" class="quicktabs-tabpage quicktabs-hide"><div class="view view-most-read-headline view-id-most_read_headline view-display-id-block_2 view-dom-id-d7a12178cbfc08c9cf9cb5f726871fb2">
        
  
  
      <div class="view-content">
      
  
  
  <div class="views-row views-row-1 views-row-odd views-row-first">
    <div class="views-field views-field-field-image"><div class="field-content"></div></div><div class="views-field views-field-title"><span class="field-content"><a href="/news/america-bloom-judges-coming-yazoo-june-18?most_read_source=month"><span>America in Bloom judges coming to Yazoo on June 18</span></a></span></div>  </div>
  
      <div class="attachment">
  
  <div class="views-row views-row-2 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/banking-pioneer-journey-bankplus-and-bryan-jones?most_read_source=month"><span>A Banking Pioneer: the journey of BankPlus and Bryan Jones</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-3 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-sports/former-nfl-player-brings-program-yazoo?most_read_source=month"><span>Former NFL player brings program to Yazoo</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-4 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/tina-ingram-face-quality-customer-service-bank-yazoo-city?most_read_source=month"><span>Tina Ingram is a face of quality customer service at Bank of Yazoo City</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-5 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/news/couple-drowns-flood-waters-after-car-leaves-road?most_read_source=month"><span>Couple drowns in flood waters after car leaves road</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-6 views-row-even views-row-last">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/beautification-projects-begin-yazoo?most_read_source=month"><span>Beautification projects begin in Yazoo</span></a></span></div>  </div>

</div>
    </div>
  
      <h2 class="element-invisible">Pages</h2><div class="item-list"><ul class="pager"><li class="pager-current first">1</li>
<li class="pager-item"><a title="Go to page 2" href="/obituaries/mary-elizabeth-dibbus-mcgowan?page=0%2C0%2C1">2</a></li>
<li class="pager-item"><a title="Go to page 3" href="/obituaries/mary-elizabeth-dibbus-mcgowan?page=0%2C0%2C2">3</a></li>
<li class="pager-ellipsis">…</li>
<li class="pager-next"><a title="Go to next page" href="/obituaries/mary-elizabeth-dibbus-mcgowan?page=0%2C0%2C1">next ›</a></li>
<li class="pager-last last"><a title="Go to last page" href="/obituaries/mary-elizabeth-dibbus-mcgowan?page=0%2C0%2C18">last »</a></li>
</ul></div>  
  
  
  
  
</div></div><div  id="quicktabs-tabpage-most_read_headline-2" class="quicktabs-tabpage quicktabs-hide"><div class="view view-most-read-headline view-id-most_read_headline view-display-id-block view-dom-id-437b8911afd114b142b21e814aad038b">
        
  
  
      <div class="view-content">
      
  
  
  <div class="views-row views-row-1 views-row-odd views-row-first">
    <div class="views-field views-field-field-image"><div class="field-content"><a href="/front-page-slideshow-news/humphries-crowned-yazoo-county-homecoming-queen"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/1003countyqueen.jpg?itok=Izwetplk" width="100" height="66" alt="" /></span></a></div></div><div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/humphries-crowned-yazoo-county-homecoming-queen?most_read_source=year"><span>Humphries crowned Yazoo County Homecoming Queen</span></a></span></div>  </div>
  
      <div class="attachment">
  
  <div class="views-row views-row-2 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/debra-crook-elected-lions-club-president?most_read_source=year"><span>Debra Crook elected Lions Club president</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-3 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/foster-care-needs-mississippi?most_read_source=year"><span>Foster care needs in Mississippi</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-4 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/pastor-heads-highways-christ?most_read_source=year"><span>Pastor heads to the highways for Christ</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-5 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/scrabble-tournament-brings-competitors-several-states?most_read_source=year"><span>Scrabble tournament brings competitors from several states</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-6 views-row-even views-row-last">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/community-good-neighbors?most_read_source=year"><span>A community of good neighbors</span></a></span></div>  </div>

</div>
    </div>
  
      <h2 class="element-invisible">Pages</h2><div class="item-list"><ul class="pager"><li class="pager-current first">1</li>
<li class="pager-item"><a title="Go to page 2" href="/obituaries/mary-elizabeth-dibbus-mcgowan?page=1">2</a></li>
<li class="pager-item"><a title="Go to page 3" href="/obituaries/mary-elizabeth-dibbus-mcgowan?page=2">3</a></li>
<li class="pager-ellipsis">…</li>
<li class="pager-next"><a title="Go to next page" href="/obituaries/mary-elizabeth-dibbus-mcgowan?page=1">next ›</a></li>
<li class="pager-last last"><a title="Go to last page" href="/obituaries/mary-elizabeth-dibbus-mcgowan?page=168">last »</a></li>
</ul></div>  
  
  
  
  
</div></div><div  id="quicktabs-tabpage-most_read_headline-3" class="quicktabs-tabpage quicktabs-hide"><div class="view view-most-read-headline view-id-most_read_headline view-display-id-block_3 view-dom-id-a80274ab4b1d65929ad894e7895930a4">
        
  
  
      <div class="view-content">
      
  
  
  <div class="views-row views-row-1 views-row-odd views-row-first">
    <div class="views-field views-field-field-image"><div class="field-content"><a href="/front-page-slideshow-news/riding-after-dream"><span><img src="//www.yazooherald.net/sites/default/files/styles/thumbnail/public/field/image/1231leiannwaters.jpg?itok=wYfxc7wP" width="100" height="75" alt="" /></span></a></div></div><div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/riding-after-dream?most_read_source=all"><span>Riding After a Dream</span></a></span></div>  </div>
  
      <div class="attachment">
  
  <div class="views-row views-row-2 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/crimm-completes-term-president?most_read_source=all"><span>Crimm completes term as president</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-3 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/obituaries/bill-beeson?most_read_source=all"><span>Bill Beeson</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-4 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/obituaries/albert-woodley-cook-jr?most_read_source=all"><span>Albert Woodley Cook Jr.</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-5 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/obituaries/shirley-summerlin?most_read_source=all"><span>Shirley Summerlin</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-6 views-row-even views-row-last">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/moonlight-and-mistletoe?most_read_source=all"><span>Moonlight and Mistletoe</span></a></span></div>  </div>

</div>
    </div>
  
      <h2 class="element-invisible">Pages</h2><div class="item-list"><ul class="pager"><li class="pager-current first">1</li>
<li class="pager-item"><a title="Go to page 2" href="/obituaries/mary-elizabeth-dibbus-mcgowan?page=0%2C0%2C0%2C1">2</a></li>
<li class="pager-item"><a title="Go to page 3" href="/obituaries/mary-elizabeth-dibbus-mcgowan?page=0%2C0%2C0%2C2">3</a></li>
<li class="pager-ellipsis">…</li>
<li class="pager-next"><a title="Go to next page" href="/obituaries/mary-elizabeth-dibbus-mcgowan?page=0%2C0%2C0%2C1">next ›</a></li>
<li class="pager-last last"><a title="Go to last page" href="/obituaries/mary-elizabeth-dibbus-mcgowan?page=0%2C0%2C0%2C744">last »</a></li>
</ul></div>  
  
  
  
  
</div></div></div></div>  </div>

</div></div> <div id="block-dfp-6ec450dc64bec11f9139a33b3f21ce9e" class="block block-dfp adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_bottom_right_widget_medium_rectangle-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_bottom_right_widget_medium_rectangle&sz=600x500&c=36058">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_bottom_right_widget_medium_rectangle&sz=600x500&c=36058">
</a>
</div>  </div>

</div></div>   </div>
</div>
        <div class="grid_0"></div>
      </section>
          </div></div>  
     
   
    
<!-- All Hail the Footer -->
  <div class="footer-wrapper"><div class="footer-wrapper-inner container_12">
    <footer id="footer" class="grid_12 clearfix">
        <div class="region region-footer">
    <div id="block-block-3" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		 <p style="text-align: center;"><span style="font-size:11px;">Copyright 2015 • The Yazoo Herald • 1035 Grand Ave. • Yazoo City, MS 39194 • (662) 746-4911</span></p>
<p style="text-align: center;"><span style="font-size:11px;">Emmerich Newspapers proudly serve the following Mississippi communities:</span></p>
<p style="font-size: 13.008px; text-align: center;"><strong><span style="font-size: 11px;"><span style="line-height: 1.538em;">ACKERMAN • <a href="http://winonatimes.com/" target="_blank">CARROLLTON</a> • <a href="http://tallahatchienews.ms" target="_blank">CHARLESTON</a> • CLARKSDALE • <a href="http://columbianprogress.com" target="_blank">COLUMBIA</a> • EUPORA • <a href="http://sctonline.net" target="_blank">FOREST</a> • <a href="http://ddtonline.com" target="_blank">GREENVILLE</a> • <a href="http://gwcommonwealth.com" target="_blank">GREENWOOD</a> • <a href="http://HubCitySPOKES.com" target="_blank">HATTIESBURG</a></span><br /><span style="line-height: 1.538em;"><a href="http://northsidesun.com" target="_blank">JACKSON</a> • <a href="http://starherald.net" target="_blank">KOSCIUSKO</a> • <a href="http://enterprise-tocsin.com" target="_blank">INDIANOLA</a> • <a href="http://thechronicle.ms" target="_blank">LAUREL</a> • LOUISVILLE • <a href="http://simpsoncounty.ms" target="_blank">MAGEE</a> • <a href="http://simpsoncounty.ms" target="_blank">MENDENHALL</a> • <a href="http://enterprise-journal.com" target="_blank">McCOMB</a> • <a href="http://newtoncountyappeal.com" target="_blank">NEWTON</a> • <a href="http://HubCitySPOKES.com" target="_blank">PETAL</a> • <a href="http://clarkecountytrib.com" target="_blank">QUITMAN</a> • <a href="http://winonatimes.com/" target="_blank">WINONA</a> • <a href="http://yazooherald.net" target="_blank">YAZOO CITY</a></span></span></strong></p>
<p style="font-size: 13.008px; text-align: center;"><strong><span style="font-size: 11px;">As well as the following communities: DUMAS, Ark., <a href="http://madisonjournal.com" target="_blank">TALLULAH, La.</a>, and FRANKLINTON, La.</span></strong></p>
<p style="text-align: center;"><span style="font-size:11px;"><em>For more information on how to extend your advertising message to these communities, <a href="/emmerich-contact-form">click here.</a></em></span></p>
   </div>

</div></div> <div id="block-dfp-yaz-footer-leaderboard" class="block block-dfp"><div class="block-inner">

	     
  <div class="content">
		<div id="dfp-ad-yaz_footer_leaderboard-wrapper" class="dfp-tag-wrapper">
<a href="https://pubads.g.doubleclick.net/gampad/jump?iu=/595218311/yaz_footer_leaderboard&sz=600x500&c=53659">
  <img src="https://pubads.g.doubleclick.net/gampad/ad?iu=/595218311/yaz_footer_leaderboard&sz=600x500&c=53659">
</a>
</div>  </div>

</div></div>   </div>
      
    </footer><!-- /footer -->
  </div></div>
 
</div><!-- page -->  <script type="text/javascript" src="//www.yazooherald.net/sites/all/modules/addthis/addthis.js?pu0l2p"></script>
</body>

</html>